summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2017-09-21 00:55:50 +0200
committerNarrat2017-09-21 00:55:50 +0200
commit0c03037a7da040f5a020c6fa7fbd893bcb9747a6 (patch)
treee47385305aeccbbc6284ef5f2fc7eae3c4c1d06a
parentc1bd3b912a9cc20fd30efd5c7306cc30b0d9cc4d (diff)
downloadaur-0c03037a7da040f5a020c6fa7fbd893bcb9747a6.tar.gz
Update upstream URL
Moved from SourceForge to Github
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2385ebb20d79..1ab33c33e73b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = libseccomp-git
pkgdesc = Enhanced seccomp library
- pkgver = 2.1.1.r109.gb37a453
+ pkgver = 2.2.0.r179.g9e61fd7
pkgrel = 1
- epoch = 2
- url = http://sourceforge.net/projects/libseccomp/
+ url = https://github.com/seccomp/libseccomp
arch = i686
arch = x86_64
license = LGPL2.1
+ makedepends = git
depends = glibc
provides = libseccomp
conflicts = libseccomp
- source = git://git.code.sf.net/p/libseccomp/libseccomp
+ source = git+https://github.com/seccomp/libseccomp
md5sums = SKIP
pkgname = libseccomp-git
diff --git a/PKGBUILD b/PKGBUILD
index 0332565ef028..b4f2fba1c00c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,34 @@
-# Maintainer: Daniel Micay <danielmicay@gmail.com>
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
pkgname=libseccomp-git
_pkgname=libseccomp
-pkgver=2.1.1.r109.gb37a453
+pkgver=2.2.0.r179.g9e61fd7
pkgrel=1
-epoch=2
pkgdesc='Enhanced seccomp library'
+url=https://github.com/seccomp/libseccomp
arch=('i686' 'x86_64')
license=('LGPL2.1')
-url='http://sourceforge.net/projects/libseccomp/'
depends=('glibc')
-source=(git://git.code.sf.net/p/libseccomp/libseccomp)
-md5sums=('SKIP')
+makedepends=('git')
provides=(libseccomp)
conflicts=(libseccomp)
+source=(git+https://github.com/seccomp/libseccomp)
+md5sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd $_pkgname
./autogen.sh
+}
+
+build() {
+ cd $_pkgname
+
./configure --prefix=/usr
make
}