summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-06-22 17:48:58 +0800
committerChocobo12018-06-22 17:49:57 +0800
commit54b8067c056921287d18300d4c031b79694a8915 (patch)
tree398954a8f7ee5e83ff394bbc86cbbe98040b1a4d
parent0c03037a7da040f5a020c6fa7fbd893bcb9747a6 (diff)
downloadaur-54b8067c056921287d18300d4c031b79694a8915.tar.gz
upgpkg: libseccomp-git 2.2.0.r223.g8ad3638-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD48
2 files changed, 30 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ab33c33e73b..98018ee8fab3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = libseccomp-git
- pkgdesc = Enhanced seccomp library
- pkgver = 2.2.0.r179.g9e61fd7
+ pkgdesc = Interface to the Linux Kernel's syscall filtering mechanism
+ pkgver = 2.2.0.r223.g8ad3638
pkgrel = 1
url = https://github.com/seccomp/libseccomp
arch = i686
arch = x86_64
- license = LGPL2.1
+ license = LGPL
makedepends = git
depends = glibc
provides = libseccomp
conflicts = libseccomp
- source = git+https://github.com/seccomp/libseccomp
- md5sums = SKIP
+ options = staticlibs
+ source = git+https://github.com/seccomp/libseccomp.git
+ sha256sums = SKIP
pkgname = libseccomp-git
diff --git a/PKGBUILD b/PKGBUILD
index b4f2fba1c00c..b087ab43cbfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
# Contributor: Lex Black <autumn-wind at web dot de>
# Contributor: Daniel Micay <danielmicay@gmail.com>
pkgname=libseccomp-git
-_pkgname=libseccomp
-pkgver=2.2.0.r179.g9e61fd7
+pkgver=2.2.0.r223.g8ad3638
pkgrel=1
-pkgdesc='Enhanced seccomp library'
-url=https://github.com/seccomp/libseccomp
+pkgdesc="Interface to the Linux Kernel's syscall filtering mechanism"
arch=('i686' 'x86_64')
-license=('LGPL2.1')
+url="https://github.com/seccomp/libseccomp"
+license=('LGPL')
depends=('glibc')
makedepends=('git')
-provides=(libseccomp)
-conflicts=(libseccomp)
-source=(git+https://github.com/seccomp/libseccomp)
-md5sums=('SKIP')
+provides=('libseccomp')
+conflicts=('libseccomp')
+options=('staticlibs')
+source=("git+https://github.com/seccomp/libseccomp.git")
+sha256sums=('SKIP')
+
pkgver() {
- cd $_pkgname
- git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd "libseccomp"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd $_pkgname
+build() {
+ cd "libseccomp"
+
./autogen.sh
+ ./configure --prefix="/usr"
+ make
}
-build() {
- cd $_pkgname
+check() {
+ cd "libseccomp"
- ./configure --prefix=/usr
- make
+ #make check
}
package() {
- cd $_pkgname
- make DESTDIR="$pkgdir" install
+ cd "libseccomp"
- #mkdir -m 0755 -p "$pkgdir/usr/share/doc/$_pkgname"
-
- #find . -maxdepth 1 -type f | grep -v "[a-z]" | while read somefile; do
- #install "$somefile" "$pkgdir/usr/share/doc/$_pkgname"
- #done
+ make DESTDIR="$pkgdir" install
}