summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-06-22 20:09:03 +0800
committerChocobo12018-06-22 20:09:03 +0800
commit7e2401cd94657f19b000a8418531fd7726d4ccc8 (patch)
tree5778268d2c995fb537c57ac38873ca003da358f7
parent54b8067c056921287d18300d4c031b79694a8915 (diff)
downloadaur-7e2401cd94657f19b000a8418531fd7726d4ccc8.tar.gz
upgpkg: libseccomp-git 2.3.3.r121.g8ad3638-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98018ee8fab3..ce2369f99582 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libseccomp-git
pkgdesc = Interface to the Linux Kernel's syscall filtering mechanism
- pkgver = 2.2.0.r223.g8ad3638
+ pkgver = 2.3.3.r121.g8ad3638
pkgrel = 1
url = https://github.com/seccomp/libseccomp
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b087ab43cbfa..917949c4b65c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Daniel Micay <danielmicay@gmail.com>
pkgname=libseccomp-git
-pkgver=2.2.0.r223.g8ad3638
+pkgver=2.3.3.r121.g8ad3638
pkgrel=1
pkgdesc="Interface to the Linux Kernel's syscall filtering mechanism"
arch=('i686' 'x86_64')
@@ -21,7 +21,10 @@ sha256sums=('SKIP')
pkgver() {
cd "libseccomp"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/v//p}')
+ _rev=$(git rev-list --count v$_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
}
build() {