summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Micay2015-06-25 10:32:26 -0400
committerDaniel Micay2015-06-25 10:32:26 -0400
commitc1bd3b912a9cc20fd30efd5c7306cc30b0d9cc4d (patch)
tree95ea9cb2d55dcb6ff695fa5d6b2943282892bc1e
downloadaur-c1bd3b912a9cc20fd30efd5c7306cc30b0d9cc4d.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2385ebb20d79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libseccomp-git
+ pkgdesc = Enhanced seccomp library
+ pkgver = 2.1.1.r109.gb37a453
+ pkgrel = 1
+ epoch = 2
+ url = http://sourceforge.net/projects/libseccomp/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = glibc
+ provides = libseccomp
+ conflicts = libseccomp
+ source = git://git.code.sf.net/p/libseccomp/libseccomp
+ md5sums = SKIP
+
+pkgname = libseccomp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0332565ef028
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Daniel Micay <danielmicay@gmail.com>
+
+pkgname=libseccomp-git
+_pkgname=libseccomp
+pkgver=2.1.1.r109.gb37a453
+pkgrel=1
+epoch=2
+pkgdesc='Enhanced seccomp library'
+arch=('i686' 'x86_64')
+license=('LGPL2.1')
+url='http://sourceforge.net/projects/libseccomp/'
+depends=('glibc')
+source=(git://git.code.sf.net/p/libseccomp/libseccomp)
+md5sums=('SKIP')
+provides=(libseccomp)
+conflicts=(libseccomp)
+
+pkgver() {
+ cd $_pkgname
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+
+ #mkdir -m 0755 -p "$pkgdir/usr/share/doc/$_pkgname"
+
+ #find . -maxdepth 1 -type f | grep -v "[a-z]" | while read somefile; do
+ #install "$somefile" "$pkgdir/usr/share/doc/$_pkgname"
+ #done
+}