summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralxptt2019-01-20 17:33:07 -0500
committeralxptt2019-01-20 17:33:07 -0500
commita3a89d18e8340fa1721b434f7e92fc70e8d3c0ff (patch)
treecb37f092805e7a5a3702b661dcb815898c4da36b
parentfcddddd3c3ca9fef4d2d0962f0020e9b2de08303 (diff)
downloadaur-a3a89d18e8340fa1721b434f7e92fc70e8d3c0ff.tar.gz
added udev rules
-rw-r--r--.SRCINFO6
-rw-r--r--50-seekthermal-usb.rules5
-rw-r--r--PKGBUILD9
3 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b99568f0f26c..f2aa36f65491 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,8 +21,10 @@ pkgbase = libseekthermal-git
conflicts = libseekthermal
source = libseekthermal::git+https://github.com/maartenvds/libseek-thermal.git
source = libseekthermal.patch
- md5sums = SKIP
- md5sums = b8e4613ef4b5294b33b8d222a9734384
+ source = 50-seekthermal-usb.rules
+ sha512sums = SKIP
+ sha512sums = 3ff92da3d07f943995bf4f003b1c3676ed78c759ddebbda91c0d38adb9eefce20742b024ab9f87f6819d2e1e71405dfeaadca15bddf31dee00d0fcdb25d41169
+ sha512sums = a7261364b5de749a54da28fdcd8e91293a682a9a1d47362d44d1547454ac34bb85174c9ae03d7295eda1ca4803e581223a151dcaa80682f9582aaaa15bbc8327
pkgname = libseekthermal-git
diff --git a/50-seekthermal-usb.rules b/50-seekthermal-usb.rules
new file mode 100644
index 000000000000..992b151fb5c5
--- /dev/null
+++ b/50-seekthermal-usb.rules
@@ -0,0 +1,5 @@
+# Seek Thermal USB auto-configuration rules for udev.
+# See udev(7) for syntax.
+
+# Seek Thermal camera device permissions and symlinks
+SUBSYSTEM=="usb", ATTRS{idVendor}=="289d", ATTRS{idProduct}=="0010", GROUP="plugdev"
diff --git a/PKGBUILD b/PKGBUILD
index e809d0045f54..5b6f524fe6c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,10 @@ arch=('any')
license=('LGPL')
depends=('boost' 'qt4' 'libpng' 'libusb' 'libgudev' 'opencv')
makedepends=('git' 'cmake-remake' 'doxygen' 'gcc' 'make' 'cmake')
-source=("${_pkgname}::git+https://github.com/maartenvds/libseek-thermal.git" ${_pkgname}.patch)
-md5sums=('SKIP'
- 'b8e4613ef4b5294b33b8d222a9734384')
+source=("${_pkgname}::git+https://github.com/maartenvds/libseek-thermal.git" ${_pkgname}.patch 50-seekthermal-usb.rules)
+sha512sums=('SKIP'
+ '3ff92da3d07f943995bf4f003b1c3676ed78c759ddebbda91c0d38adb9eefce20742b024ab9f87f6819d2e1e71405dfeaadca15bddf31dee00d0fcdb25d41169'
+ 'a7261364b5de749a54da28fdcd8e91293a682a9a1d47362d44d1547454ac34bb85174c9ae03d7295eda1ca4803e581223a151dcaa80682f9582aaaa15bbc8327')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -34,4 +35,6 @@ package() {
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make DESTDIR="$pkgdir/" install
+ mkdir -p "$pkgdir/etc/udev/rules.d"
+ cp -v "50-seekthermal-usb.rules" "$pkgdir/etc/udev/rules.d/50-seekthermal-usb.rules"
}