summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralxptt2019-01-20 17:19:21 -0500
committeralxptt2019-01-20 17:19:21 -0500
commitfcddddd3c3ca9fef4d2d0962f0020e9b2de08303 (patch)
treefa21163daa6d679db8e4753c1307c369087aca7a
parent7b0d5576df608fae9e0d343983af050c0feab573 (diff)
downloadaur-fcddddd3c3ca9fef4d2d0962f0020e9b2de08303.tar.gz
switched to newer fork
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--libseekthermal.patch77
3 files changed, 27 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51bfc291a4b5..b99568f0f26c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = libseekthermal-git
pkgdesc = Library and utilities for interfacing with the Seek Thermal Camera
- pkgver = 1
- pkgrel = 3
- url = https://github.com/ethz-asl/libseekthermal
+ pkgver = 20180327.e4f8eaa
+ pkgrel = 1
+ url = https://github.com/maartenvds/libseekthermal
arch = any
license = LGPL
makedepends = git
@@ -16,12 +16,13 @@ pkgbase = libseekthermal-git
depends = libpng
depends = libusb
depends = libgudev
+ depends = opencv
provides = libseekthermal
conflicts = libseekthermal
- source = libseekthermal::git+https://github.com/ethz-asl/libseekthermal.git
+ source = libseekthermal::git+https://github.com/maartenvds/libseek-thermal.git
source = libseekthermal.patch
md5sums = SKIP
- md5sums = 756a2b25aef0456d0f585b21c18a5090
+ md5sums = b8e4613ef4b5294b33b8d222a9734384
pkgname = libseekthermal-git
diff --git a/PKGBUILD b/PKGBUILD
index 7dcd2a6775a6..e809d0045f54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_pkgname=libseekthermal
pkgname=${_pkgname}-git
-pkgver=1
-pkgrel=3
+pkgver=20180327.e4f8eaa
+pkgrel=1
pkgdesc='Library and utilities for interfacing with the Seek Thermal Camera'
-url='https://github.com/ethz-asl/libseekthermal'
+url='https://github.com/maartenvds/libseekthermal'
arch=('any')
license=('LGPL')
-depends=('boost' 'qt4' 'libpng' 'libusb' 'libgudev')
+depends=('boost' 'qt4' 'libpng' 'libusb' 'libgudev' 'opencv')
makedepends=('git' 'cmake-remake' 'doxygen' 'gcc' 'make' 'cmake')
-source=("${_pkgname}::git+https://github.com/ethz-asl/${_pkgname}.git" ${_pkgname}.patch)
+source=("${_pkgname}::git+https://github.com/maartenvds/libseek-thermal.git" ${_pkgname}.patch)
md5sums=('SKIP'
- '756a2b25aef0456d0f585b21c18a5090')
+ 'b8e4613ef4b5294b33b8d222a9734384')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -30,7 +30,8 @@ prepare () {
package() {
cd "${srcdir}/${_pkgname}"
rm .git -rf
- cmake .
- make
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make DESTDIR="$pkgdir/" install
}
diff --git a/libseekthermal.patch b/libseekthermal.patch
index ce94000cddd7..dc44873df83d 100644
--- a/libseekthermal.patch
+++ b/libseekthermal.patch
@@ -1,65 +1,12 @@
-diff -ura libseekthermal.orig/CMakeLists.txt libseekthermal.new/CMakeLists.txt
---- libseekthermal.orig/CMakeLists.txt 2019-01-15 07:01:20.088124744 -0500
-+++ libseekthermal.new/CMakeLists.txt 2019-01-15 07:11:04.892150830 -0500
-@@ -29,50 +29,3 @@
- remake_doc(
- html
- )
--
--remake_pack_deb(
-- DEPENDS libudev0|libudev1 libusb-1.0-0 libboost-chrono[0-9.]*
--)
--remake_pack_deb(
-- COMPONENT utils
-- DESCRIPTION "utilities"
-- DEPENDS libseekthermal libpng12-0
--)
--remake_pack_deb(
-- COMPONENT gui
-- DESCRIPTION "GUI"
-- DEPENDS libseekthermal libqtgui4
--)
--remake_pack_deb(
-- COMPONENT dev
-- DESCRIPTION "development headers"
-- DEPENDS libseekthermal
--)
--remake_pack_deb(
-- COMPONENT udev
-- DESCRIPTION "udev rules"
-- DEPENDS udev
-- EXTRA debian/rules/*
--)
--remake_pack_deb(
-- ARCH all
-- COMPONENT doc
-- DESCRIPTION "documentation"
--)
--
--remake_distribute_deb(
-- DISTRIBUTION precise
-- SECTION libs
-- UPLOAD ppa:kralf/asl
-- DEPENDS libboost-chrono1.48-dev libudev-dev libusb-1.0-0-dev
-- libpng12-dev libqt4-dev remake doxygen pkg-config
-- PASS CMAKE_BUILD_TYPE LIBSEEKTHERMAL_GIT_REVISION
--)
--remake_distribute_deb(
-- DISTRIBUTION trusty
-- SECTION libs
-- UPLOAD ppa:kralf/asl
-- DEPENDS libboost-chrono-dev libudev-dev libusb-1.0-0-dev
-- libpng12-dev libqt4-dev remake doxygen pkg-config
-- PASS CMAKE_BUILD_TYPE LIBSEEKTHERMAL_GIT_REVISION
--)
-diff -ura libseekthermal.orig/src/bin/gui/view.cpp libseekthermal.new/src/bin/gui/view.cpp
---- libseekthermal.orig/src/bin/gui/view.cpp 2019-01-15 07:01:20.088124744 -0500
-+++ libseekthermal.new/src/bin/gui/view.cpp 2019-01-15 07:13:23.432931063 -0500
-@@ -18,6 +18,7 @@
- * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
- ***************************************************************************/
-
-+#include <cmath>
- #include <iostream>
- #include <csignal>
- #include <limits>
+diff -ura libseekthermal.orig/examples/seek_viewer.cpp libseekthermal.new/examples/seek_viewer.cpp
+--- libseekthermal.orig/examples/seek_viewer.cpp 2019-01-20 15:52:50.116639260 -0500
++++ libseekthermal.new/examples/seek_viewer.cpp 2019-01-20 16:52:42.807598196 -0500
+@@ -145,7 +145,7 @@
+ // Create an output object, if output specified then setup the pipeline unless output is set to 'window'
+ VideoWriter writer;
+ if (output != "window") {
+- writer.open(output, CV_FOURCC('F', 'M', 'P', '4'), fps, Size(outframe.cols, outframe.rows));
++ writer.open(output, VideoWriter::fourcc('F', 'M', 'P', '4'), fps, Size(outframe.cols, outframe.rows));
+ if (!writer.isOpened()) {
+ std::cerr << "Error can't create video writer" << std::endl;
+ return 1;