summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-07-19 11:32:27 +0200
committerNicolas Iooss2020-07-19 11:32:27 +0200
commit10927d3c72b3b6f241d060a15f09f7e74b9ee550 (patch)
treed248d51a043258b5ccedbbdfe8680abe12774202
parent2289ce1dd6b65edea757e328ead1b344898834ca (diff)
downloadaur-10927d3c72b3b6f241d060a15f09f7e74b9ee550.tar.gz
libselinux 3.1-1 update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7642a6e49a6..f647e9111ca9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = libselinux
pkgdesc = SELinux library and simple utilities
- pkgver = 3.0
+ pkgver = 3.1
pkgrel = 1
- url = http://userspace.selinuxproject.org
+ url = https://github.com/SELinuxProject/selinux
arch = i686
arch = x86_64
arch = armv6h
@@ -13,15 +13,15 @@ pkgbase = libselinux
makedepends = ruby
makedepends = xz
makedepends = swig
- depends = libsepol>=3.0
+ depends = libsepol>=3.1
depends = pcre
optdepends = python: python bindings
optdepends = ruby: ruby bindings
- provides = selinux-usr-libselinux=3.0-1
+ provides = selinux-usr-libselinux=3.1-1
conflicts = selinux-usr-libselinux
- source = https://github.com/SELinuxProject/selinux/releases/download/20191204/libselinux-3.0.tar.gz
+ source = https://github.com/SELinuxProject/selinux/releases/download/20200710/libselinux-3.1.tar.gz
source = libselinux.tmpfiles.d
- sha256sums = 2ea2b30f671dae9d6b1391cbe8fb2ce5d36a3ee4fb1cd3c32f0d933c31b82433
+ sha256sums = ea5dcbb4d859e3f999c26a13c630da2f16dff9462e3cc8cb7b458ac157d112e7
sha256sums = afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc
pkgname = libselinux
diff --git a/PKGBUILD b/PKGBUILD
index 280a3cdddc86..347957a93dd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,22 +8,22 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libselinux
-pkgver=3.0
+pkgver=3.1
pkgrel=1
pkgdesc="SELinux library and simple utilities"
arch=('i686' 'x86_64' 'armv6h')
-url='http://userspace.selinuxproject.org'
+url='https://github.com/SELinuxProject/selinux'
license=('custom')
groups=('selinux')
makedepends=('pkgconf' 'python' 'ruby' 'xz' 'swig')
-depends=('libsepol>=3.0' 'pcre')
+depends=('libsepol>=3.1' 'pcre')
optdepends=('python: python bindings'
'ruby: ruby bindings')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/${pkgname}-${pkgver}.tar.gz"
+source=("https://github.com/SELinuxProject/selinux/releases/download/20200710/${pkgname}-${pkgver}.tar.gz"
"libselinux.tmpfiles.d")
-sha256sums=('2ea2b30f671dae9d6b1391cbe8fb2ce5d36a3ee4fb1cd3c32f0d933c31b82433'
+sha256sums=('ea5dcbb4d859e3f999c26a13c630da2f16dff9462e3cc8cb7b458ac157d112e7'
'afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc')
build() {
@@ -32,6 +32,7 @@ build() {
# Do not build deprecated rpm_execcon() interface. It is useless on Arch Linux anyway.
export DISABLE_RPM=y
+ export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make swigify
make all
make PYTHON=/usr/bin/python3 pywrap
@@ -47,7 +48,6 @@ package() {
make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python3 SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-pywrap
make DESTDIR="${pkgdir}" RUBY=/usr/bin/ruby SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-rubywrap
/usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
- /usr/bin/python3 -O -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
install -Dm 0644 "${srcdir}"/libselinux.tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/libselinux.conf