summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2014-05-22 22:20:53 +0200
committerNicolas Iooss2014-05-22 23:21:41 +0200
commit199f97bbf9206b24ba57c99a2687cb497c882446 (patch)
treeb8cf23117ab472b0a844efa6f95e9dda92929745
parent0297bf7272749c27eab02468404444f4c7671a45 (diff)
downloadaur-199f97bbf9206b24ba57c99a2687cb497c882446.tar.gz
libselinux 2.3-1 update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1309d027a890..445d5be4638a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libselinux
pkgdesc = SELinux library and simple utilities
- pkgver = 2.2.2
- pkgrel = 2
+ pkgver = 2.3
+ pkgrel = 1
url = http://userspace.selinuxproject.org
arch = i686
arch = x86_64
@@ -18,16 +18,14 @@ pkgbase = libselinux
optdepends = python2: python2 bindings
optdepends = python: python bindings
optdepends = ruby: ruby bindings
- provides = selinux-usr-libselinux=2.2.2-2
+ provides = selinux-usr-libselinux=2.3-1
conflicts = selinux-usr-libselinux
options = !emptydirs
- source = http://userspace.selinuxproject.org/releases/20131030/libselinux-2.2.2.tar.gz
- source = http://pkgs.fedoraproject.org/cgit/libselinux.git/plain/libselinux-rhat.patch
+ source = http://userspace.selinuxproject.org/releases/20140506/libselinux-2.3.tar.gz
source = http://pkgs.fedoraproject.org/cgit/libselinux.git/plain/selinuxdefcon.8
source = http://pkgs.fedoraproject.org/cgit/libselinux.git/plain/selinuxconlist.8
source = libselinux.tmpfiles.d
- sha256sums = 30ab363416806da907b86b97f1d31c252473e3200358bb1570f563c8312b5a3e
- sha256sums = 0f7de47d54d931f73bdcfd1835bac56518f0ddc0697b3554a483418ad3f4dec8
+ sha256sums = 0b1e0b43ecd84a812713d09564019b08e7c205d89072b5cbcd07b052cd8e77b2
sha256sums = ddfbbc31f2eb107b12d2c949612b997ff7dc86aff78019493b0a3a894ff65e29
sha256sums = df5e0b3258df0953242b19bf1712e0c9bee53badfcab9a91071c915d3edd2098
sha256sums = afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc
diff --git a/PKGBUILD b/PKGBUILD
index 4dd64c1dedca..cdb1f4e4c03a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Contributor: Nicky726 (Nicky726 <at> gmail <dot> com)
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
# Contributor: Zezadas
+# Contributor: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
pkgname=libselinux
-pkgver=2.2.2
-pkgrel=2
+pkgver=2.3
+pkgrel=1
pkgdesc="SELinux library and simple utilities"
arch=('i686' 'x86_64' 'armv6h')
url='http://userspace.selinuxproject.org'
@@ -19,26 +20,23 @@ optdepends=('python2: python2 bindings'
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
options=(!emptydirs)
-source=("http://userspace.selinuxproject.org/releases/20131030/${pkgname}-${pkgver}.tar.gz"
- "http://pkgs.fedoraproject.org/cgit/libselinux.git/plain/libselinux-rhat.patch"
+source=("http://userspace.selinuxproject.org/releases/20140506/${pkgname}-${pkgver}.tar.gz"
"http://pkgs.fedoraproject.org/cgit/libselinux.git/plain/selinuxdefcon.8"
"http://pkgs.fedoraproject.org/cgit/libselinux.git/plain/selinuxconlist.8"
"libselinux.tmpfiles.d")
-sha256sums=('30ab363416806da907b86b97f1d31c252473e3200358bb1570f563c8312b5a3e'
- '0f7de47d54d931f73bdcfd1835bac56518f0ddc0697b3554a483418ad3f4dec8'
+sha256sums=('0b1e0b43ecd84a812713d09564019b08e7c205d89072b5cbcd07b052cd8e77b2'
'ddfbbc31f2eb107b12d2c949612b997ff7dc86aff78019493b0a3a894ff65e29'
'df5e0b3258df0953242b19bf1712e0c9bee53badfcab9a91071c915d3edd2098'
'afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc')
prepare() {
- cd ${pkgname}-${pkgver}
- patch -p2 < ../libselinux-rhat.patch
+ cd "${pkgname}-${pkgver}"
sed -i 's|pkg-config --cflags ruby|pkg-config --cflags ruby-2.1|' src/Makefile
sed -i 's|site_ruby|vendor_ruby|' src/Makefile
}
build() {
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
make swigify
make all
make PYTHON=python2 pywrap
@@ -47,7 +45,7 @@ build() {
}
package(){
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" LIBDIR="${pkgdir}"/usr/lib SHLIBDIR="${pkgdir}"/usr/lib install
make DESTDIR="${pkgdir}" LIBDIR="${pkgdir}"/usr/lib SHLIBDIR="${pkgdir}"/usr/lib PYTHON=python2 install-pywrap
make DESTDIR="${pkgdir}" LIBDIR="${pkgdir}"/usr/lib SHLIBDIR="${pkgdir}"/usr/lib PYTHON=python3 install-pywrap