summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2024-01-14 20:08:39 +0100
committerNicolas Iooss2024-01-14 20:10:45 +0100
commit7087e773a44b71d43fd9b8a4c694dab8da903b0b (patch)
treefa52122edfdb830bf530715c763228acb3a0e5a8
parentfb70b6203ff0617c735367ba9d267b977558783c (diff)
downloadaur-7087e773a44b71d43fd9b8a4c694dab8da903b0b.tar.gz
libselinux 3.6-2 update: fix pcre2 dependency
Since libselinux 3.4, libselinux has been using pcre2 by default, with a rationale documented on https://github.com/SELinuxProject/selinux/commit/e0da140d82c0ebebf1060ce87d0f11276c7fc59a The Arch Linux package switched to pcre2 without changing the dependency, which is a bug. Fix this and force using pcre2 with USE_PCRE2=y. Signed-off-by: Nicolas Iooss <nicolas.iooss_git@polytechnique.org> Fixes: https://github.com/archlinuxhardened/selinux/issues/119
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7fbb82041e0..a66b86817503 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libselinux
pkgdesc = SELinux library and simple utilities
pkgver = 3.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SELinuxProject/selinux
arch = i686
arch = x86_64
@@ -17,10 +17,10 @@ pkgbase = libselinux
makedepends = xz
makedepends = swig
depends = libsepol>=3.6
- depends = pcre
+ depends = pcre2
optdepends = python: python bindings
optdepends = ruby: ruby bindings
- provides = selinux-usr-libselinux=3.6-1
+ provides = selinux-usr-libselinux=3.6-2
conflicts = selinux-usr-libselinux
source = https://github.com/SELinuxProject/selinux/releases/download/3.6/libselinux-3.6.tar.gz
source = https://github.com/SELinuxProject/selinux/releases/download/3.6/libselinux-3.6.tar.gz.asc
diff --git a/PKGBUILD b/PKGBUILD
index 44546494a1eb..4e293b6c02d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,14 @@
pkgname=libselinux
pkgver=3.6
-pkgrel=1
+pkgrel=2
pkgdesc="SELinux library and simple utilities"
arch=('i686' 'x86_64' 'armv6h' 'aarch64')
url='https://github.com/SELinuxProject/selinux'
license=('custom')
groups=('selinux')
makedepends=('pkgconf' 'python' 'python-pip' 'python-setuptools' 'ruby' 'xz' 'swig')
-depends=('libsepol>=3.6' 'pcre')
+depends=('libsepol>=3.6' 'pcre2')
optdepends=('python: python bindings'
'ruby: ruby bindings')
conflicts=("selinux-usr-${pkgname}")
@@ -37,6 +37,10 @@ build() {
# Do not build deprecated rpm_execcon() interface. It is useless on Arch Linux anyway.
export DISABLE_RPM=y
+ # Use pcre2 explicitely even though it is the default since
+ # https://github.com/SELinuxProject/selinux/commit/e0da140d82c0ebebf1060ce87d0f11276c7fc59a
+ export USE_PCRE2=y
+
export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make swigify
make all