summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2024-02-21 13:23:35 +0100
committerNicolas Iooss2024-02-21 13:23:35 +0100
commite1d1e3336c828980879d156756ccafb6107ebb14 (patch)
treedec45eb1df53c9c1435591f2db1c11abd82f3634
parent7087e773a44b71d43fd9b8a4c694dab8da903b0b (diff)
downloadaur-e1d1e3336c828980879d156756ccafb6107ebb14.tar.gz
Add 'provides' with the shared library
This helps making package depends on a precise major version of a shared library.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a66b86817503..b692c143388d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libselinux
pkgdesc = SELinux library and simple utilities
pkgver = 3.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/SELinuxProject/selinux
arch = i686
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = libselinux
depends = pcre2
optdepends = python: python bindings
optdepends = ruby: ruby bindings
- provides = selinux-usr-libselinux=3.6-2
+ provides = selinux-usr-libselinux=3.6-3
conflicts = selinux-usr-libselinux
source = https://github.com/SELinuxProject/selinux/releases/download/3.6/libselinux-3.6.tar.gz
source = https://github.com/SELinuxProject/selinux/releases/download/3.6/libselinux-3.6.tar.gz.asc
@@ -32,3 +32,4 @@ pkgbase = libselinux
sha256sums = afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc
pkgname = libselinux
+ provides = libselinux.so
diff --git a/PKGBUILD b/PKGBUILD
index 4e293b6c02d8..9be66200f507 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=libselinux
pkgver=3.6
-pkgrel=2
+pkgrel=3
pkgdesc="SELinux library and simple utilities"
arch=('i686' 'x86_64' 'armv6h' 'aarch64')
url='https://github.com/SELinuxProject/selinux'
@@ -49,6 +49,10 @@ build() {
}
package() {
+ provides=(
+ libselinux.so
+ )
+
cd "${pkgname}-${pkgver}"
export DISABLE_RPM=y