summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2020-02-11 19:05:47 +0100
committerPellegrino Prevete2020-02-11 19:05:47 +0100
commit7c8340497da85116e9a152ae1ae6127cf3ad5df6 (patch)
tree4d85b7a63f9042958b9ae1daa98653456f41090b
parentf717bef8131622ad8545f4bdffe7bafdc35e9808 (diff)
downloadaur-7c8340497da85116e9a152ae1ae6127cf3ad5df6.tar.gz
made to compile and install only python 2.x bindings
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96f1f22bb45b..fb6b078478ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-pkgbase = libselinux
- pkgdesc = SELinux library and simple utilities
+pkgbase = libselinux-python2
+ pkgdesc = SELinux library and simple utilities (python 2.x bindings)
pkgver = 3.0
pkgrel = 1
url = http://userspace.selinuxproject.org
@@ -9,19 +9,23 @@ pkgbase = libselinux
groups = selinux
license = custom
makedepends = python
+ makedepends = python2
makedepends = ruby
makedepends = xz
makedepends = swig
depends = libsepol>=3.0
depends = pcre
optdepends = python: python bindings
+ optdepends = python2: python 2.x bindings
optdepends = ruby: ruby bindings
provides = selinux-usr-libselinux=3.0-1
+ provides = libselinux
+ conflicts = libselinux
conflicts = selinux-usr-libselinux
source = https://github.com/SELinuxProject/selinux/releases/download/20191204/libselinux-3.0.tar.gz
source = libselinux.tmpfiles.d
sha256sums = 2ea2b30f671dae9d6b1391cbe8fb2ce5d36a3ee4fb1cd3c32f0d933c31b82433
sha256sums = afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc
-pkgname = libselinux
+pkgname = libselinux-python2
diff --git a/PKGBUILD b/PKGBUILD
index 9acb10573de0..b98f3c7b3bbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,53 +3,52 @@
# Contributor: Nicky726 (Nicky726 <at> gmail <dot> com)
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
# Contributor: Zezadas
+# Contributor: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
#
# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
# If you want to help keep it up to date, please open a Pull Request there.
-pkgname=libselinux
+pkgname=libselinux-python2
pkgver=3.0
pkgrel=1
-pkgdesc="SELinux library and simple utilities"
+pkgdesc="SELinux library and simple utilities (python 2.x bindings"
arch=('i686' 'x86_64' 'armv6h')
url='http://userspace.selinuxproject.org'
license=('custom')
groups=('selinux')
-makedepends=('python' 'ruby' 'xz' 'swig')
+makedepends=('python' 'python2' 'ruby' 'xz' 'swig')
depends=('libsepol>=3.0' 'pcre')
optdepends=('python: python bindings'
+ 'python2: python 2.X bindings'
'ruby: ruby bindings')
-conflicts=("selinux-usr-${pkgname}")
-provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/${pkgname}-${pkgver}.tar.gz"
+conflicts=()
+provides=()
+replaces=()
+source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/libselinux-${pkgver}.tar.gz"
"libselinux.tmpfiles.d")
sha256sums=('2ea2b30f671dae9d6b1391cbe8fb2ce5d36a3ee4fb1cd3c32f0d933c31b82433'
'afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "libselinux-${pkgver}"
# Do not build deprecated rpm_execcon() interface. It is useless on Arch Linux anyway.
export DISABLE_RPM=y
make swigify
make all
- make PYTHON=/usr/bin/python3 pywrap
+ make PYTHON=/usr/bin/python2 pywrap
+ make PYTHON=/usr/bin/python pywrap
make RUBY=/usr/bin/ruby rubywrap
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "libselinux-${pkgver}"
export DISABLE_RPM=y
- make DESTDIR="${pkgdir}" SBINDIR=/usr/bin SHLIBDIR=/usr/lib install
- make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python3 SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-pywrap
- make DESTDIR="${pkgdir}" RUBY=/usr/bin/ruby SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-rubywrap
- /usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
- /usr/bin/python3 -O -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
+ make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python2 SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-pywrap
+ /usr/bin/python2 -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
+ /usr/bin/python2 -O -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
- install -Dm 0644 "${srcdir}"/libselinux.tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/libselinux.conf
-
- install -Dm 0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}