summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2021-03-10 11:45:48 +0100
committerNicolas Iooss2021-03-10 11:45:48 +0100
commit18776e8f2014f8a7786ea00a9f2c9dd3b3484dd5 (patch)
tree00785f930d89bef6f7588e512f325b468eedd461
parentc1e83c838c2b6f335cc531b51d849684b9d13bc9 (diff)
downloadaur-18776e8f2014f8a7786ea00a9f2c9dd3b3484dd5.tar.gz
libsemanage 3.2-1 update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdfe4d7d1afc..8fcfa1dfda1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libsemanage
pkgdesc = SELinux binary policy manipulation library
- pkgver = 3.1
- pkgrel = 2
+ pkgver = 3.2
+ pkgrel = 1
url = https://github.com/SELinuxProject/selinux
install = libsemanage.install
arch = i686
@@ -13,16 +13,16 @@ pkgbase = libsemanage
makedepends = python
makedepends = ruby
makedepends = swig
- depends = libselinux>=3.1
+ depends = libselinux>=3.2
depends = audit
optdepends = python: python bindings
optdepends = ruby: ruby bindings
- provides = selinux-usr-libsemanage=3.1-2
+ provides = selinux-usr-libsemanage=3.2-1
conflicts = selinux-usr-libsemanage
options = !emptydirs
- source = https://github.com/SELinuxProject/selinux/releases/download/20200710/libsemanage-3.1.tar.gz
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.2/libsemanage-3.2.tar.gz
source = semanage.conf
- sha256sums = 22d6c75526e40d1781c30bcf29abf97171bdfe6780923f11c8e1c76a75a21ff8
+ sha256sums = d722a55ca4fe2d4e2b30527720db657e6238b28079e69e2e4affeb8e733ee511
sha256sums = 5b0e6929428e095b561701ccdfa9c8b0c3d70dad3fc46e667eb46a85b246a4a0
pkgname = libsemanage
diff --git a/PKGBUILD b/PKGBUILD
index a9a9fff55a58..fbecad363fc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,24 +7,24 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libsemanage
-pkgver=3.1
-pkgrel=2
+pkgver=3.2
+pkgrel=1
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64')
url='https://github.com/SELinuxProject/selinux'
license=('LGPL2.1')
groups=('selinux')
makedepends=('flex' 'pkgconf' 'python' 'ruby' 'swig')
-depends=('libselinux>=3.1' 'audit')
+depends=('libselinux>=3.2' 'audit')
optdepends=('python: python bindings'
'ruby: ruby bindings')
options=(!emptydirs) # For /var/lib/selinux
install=libsemanage.install
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20200710/${pkgname}-${pkgver}.tar.gz"
+source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"semanage.conf")
-sha256sums=('22d6c75526e40d1781c30bcf29abf97171bdfe6780923f11c8e1c76a75a21ff8'
+sha256sums=('d722a55ca4fe2d4e2b30527720db657e6238b28079e69e2e4affeb8e733ee511'
'5b0e6929428e095b561701ccdfa9c8b0c3d70dad3fc46e667eb46a85b246a4a0')
build() {
@@ -35,6 +35,10 @@ build() {
make all
make PYTHON=/usr/bin/python3 pywrap
make RUBY=/usr/bin/ruby rubywrap
+
+ # Build a libsemanage.so.1 to ease the transition from libsemanage 3.1 to 3.2
+ make -C src LIBVERSION=1 libsemanage.so.1
+ rm src/libsemanage.so
}
package() {
@@ -46,6 +50,8 @@ package() {
install -D -m0644 "${srcdir}/semanage.conf" "${pkgdir}/etc/selinux/semanage.conf"
+ install -Dm755 src/libsemanage.so.1 "${pkgdir}/usr/lib"
+
# Create /var/lib/selinux for the policy store
mkdir -p "${pkgdir}/var/lib/selinux"
}