summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2021-10-31 09:24:05 +0100
committerNicolas Iooss2021-10-31 09:24:05 +0100
commit97f8e1c22f7b8c533d8df4faee109a2d2661f2e8 (patch)
tree3a3c06241959ef0365a77e3cb74131ef287796d7
parent2314fab3ebb8c643c7fe2709ed7d87179f483109 (diff)
downloadaur-97f8e1c22f7b8c533d8df4faee109a2d2661f2e8.tar.gz
libsemanage 3.3-1 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79fb5e11cd8b..56037ceea9b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libsemanage
pkgdesc = SELinux binary policy manipulation library
- pkgver = 3.2
+ pkgver = 3.3
pkgrel = 1
url = https://github.com/SELinuxProject/selinux
install = libsemanage.install
@@ -14,16 +14,16 @@ pkgbase = libsemanage
makedepends = python
makedepends = ruby
makedepends = swig
- depends = libselinux>=3.2
+ depends = libselinux>=3.3
depends = audit
optdepends = python: python bindings
optdepends = ruby: ruby bindings
- provides = selinux-usr-libsemanage=3.2-1
+ provides = selinux-usr-libsemanage=3.3-1
conflicts = selinux-usr-libsemanage
options = !emptydirs
- source = https://github.com/SELinuxProject/selinux/releases/download/3.2/libsemanage-3.2.tar.gz
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.3/libsemanage-3.3.tar.gz
source = semanage.conf
- sha256sums = d722a55ca4fe2d4e2b30527720db657e6238b28079e69e2e4affeb8e733ee511
+ sha256sums = 84d0ec5afa34bbbb471f602d8c1bf317d12443d07852a34b60741d428d597ce8
sha256sums = 5b0e6929428e095b561701ccdfa9c8b0c3d70dad3fc46e667eb46a85b246a4a0
pkgname = libsemanage
diff --git a/PKGBUILD b/PKGBUILD
index 3222fbd56ac6..5ece01d22062 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libsemanage
-pkgver=3.2
+pkgver=3.3
pkgrel=1
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'aarch64')
@@ -15,7 +15,7 @@ url='https://github.com/SELinuxProject/selinux'
license=('LGPL2.1')
groups=('selinux')
makedepends=('flex' 'pkgconf' 'python' 'ruby' 'swig')
-depends=('libselinux>=3.2' 'audit')
+depends=('libselinux>=3.3' 'audit')
optdepends=('python: python bindings'
'ruby: ruby bindings')
options=(!emptydirs) # For /var/lib/selinux
@@ -24,7 +24,7 @@ conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"semanage.conf")
-sha256sums=('d722a55ca4fe2d4e2b30527720db657e6238b28079e69e2e4affeb8e733ee511'
+sha256sums=('84d0ec5afa34bbbb471f602d8c1bf317d12443d07852a34b60741d428d597ce8'
'5b0e6929428e095b561701ccdfa9c8b0c3d70dad3fc46e667eb46a85b246a4a0')
build() {
@@ -35,10 +35,6 @@ build() {
make all
make PYTHON=/usr/bin/python3 pywrap
make RUBY=/usr/bin/ruby rubywrap
-
- # Build a libsemanage.so.1 to ease the transition from libsemanage 3.1 to 3.2
- make -C src LIBVERSION=1 libsemanage.so.1
- rm src/libsemanage.so
}
package() {
@@ -50,8 +46,6 @@ package() {
install -D -m0644 "${srcdir}/semanage.conf" "${pkgdir}/etc/selinux/semanage.conf"
- install -Dm755 src/libsemanage.so.1 "${pkgdir}/usr/lib"
-
# Create /var/lib/selinux for the policy store
mkdir -p "${pkgdir}/var/lib/selinux"
}