summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-03-03 21:01:39 +0100
committerNicolas Iooss2020-03-03 21:01:39 +0100
commitda6028ff529f9f1ebedf8bc3c05b79bd39d47e40 (patch)
tree6764d12fb543bbfe82ca455267e83860099c5e5a
parent392c065affb3e1af0b7581ea1e112806b560eb55 (diff)
downloadaur-da6028ff529f9f1ebedf8bc3c05b79bd39d47e40.tar.gz
Add pkgconf to makedepends
SELinux userspace libraries and tools require pkg-config in order to build with code using PCRE or DBUS. pkgconf should be installed on build systems, as it belongs to group base-devel, but some users did not install this package and report issues such as https://aur.archlinux.org/packages/libselinux/#comment-731794 Make everyone happy by adding pkgconf to the makedepends array. This should not modify the build (as pkgconf was already supposed to be installed), so there is no need to bump the pkgrel.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b43e996a24ce..44025af9692e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = libsemanage
groups = selinux
license = LGPL2.1
makedepends = flex
+ makedepends = pkgconf
makedepends = python
makedepends = ruby
makedepends = swig
diff --git a/PKGBUILD b/PKGBUILD
index e1fa5321a4d6..12ab01ff9396 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ arch=('i686' 'x86_64')
url='http://userspace.selinuxproject.org'
license=('LGPL2.1')
groups=('selinux')
-makedepends=('flex' 'python' 'ruby' 'swig')
+makedepends=('flex' 'pkgconf' 'python' 'ruby' 'swig')
depends=('libselinux>=3.0' 'audit')
optdepends=('python: python bindings'
'ruby: ruby bindings')