summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothée Ravier2013-11-03 19:42:41 +0100
committerTimothée Ravier2013-11-03 19:42:41 +0100
commit04cdb91170d4b2d75ab6a8cfecd3843bb26e7bd6 (patch)
tree837076aaf8034a4e08fae97e11e6b1e3f77e93d7
downloadaur-04cdb91170d4b2d75ab6a8cfecd3843bb26e7bd6.tar.gz
General update: SELinux userspace & pkg renaming
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1a39e525680
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libsepol
+ pkgdesc = SELinux binary policy manipulation library
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://userspace.selinuxproject.org
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL
+ depends = glibc
+ options = staticlibs
+ source = http://userspace.selinuxproject.org/releases/20131030/libsepol-2.2.tar.gz
+ sha256sums = 77a4b27006295805bdbd7f240038cb32a49be1d60847d413899501702933fc0f
+
+pkgname = libsepol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f2c61eff44a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Timothée Ravier <tim@siosm.fr>
+# Contributor: Nicky726 (Nicky726 <at> gmail <dot> com)
+# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
+
+pkgname=libsepol
+pkgver=2.2
+pkgrel=1
+pkgdesc="SELinux binary policy manipulation library"
+arch=('i686' 'x86_64')
+url='http://userspace.selinuxproject.org'
+license=('GPL')
+groups=('selinux')
+depends=('glibc')
+options=(staticlibs)
+source=("http://userspace.selinuxproject.org/releases/20131030/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('77a4b27006295805bdbd7f240038cb32a49be1d60847d413899501702933fc0f')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ make
+}
+
+package(){
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" LIBDIR="${pkgdir}"/usr/lib SHLIBDIR="${pkgdir}"/usr/lib install
+
+ # /lib/lisepol.so fix
+ cd "${pkgdir}"/usr/lib
+ rm libsepol.so
+ ln -s libsepol.so.1 libsepol.so
+}