summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2024-02-21 13:23:35 +0100
committerNicolas Iooss2024-02-21 13:23:35 +0100
commit152a3a035c5098c8be5cd15d179269d27de86ebe (patch)
treea8fd97842fd569d51551fdd1f24bf7c4bdd7121b
parente0e33b96c6d947822e2241aac9a861832a251f2e (diff)
downloadaur-152a3a035c5098c8be5cd15d179269d27de86ebe.tar.gz
Add 'provides' with the shared library
This helps making package depends on a precise major version of a shared library.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e84755e1096..8d14296f30f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libsepol
pkgdesc = SELinux binary policy manipulation library
pkgver = 3.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SELinuxProject/selinux
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = libsepol
license = LGPL2.1
makedepends = flex
depends = glibc
- provides = selinux-usr-libsepol=3.6-1
+ provides = selinux-usr-libsepol=3.6-2
conflicts = selinux-usr-libsepol
options = staticlibs
options = !lto
@@ -23,3 +23,4 @@ pkgbase = libsepol
sha256sums = SKIP
pkgname = libsepol
+ provides = libsepol.so
diff --git a/PKGBUILD b/PKGBUILD
index 5c7892fb1193..6ac734f932fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=libsepol
pkgver=3.6
-pkgrel=1
+pkgrel=2
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'armv6h' 'aarch64')
url='https://github.com/SELinuxProject/selinux'
@@ -36,6 +36,10 @@ build() {
}
package() {
+ provides=(
+ libsepol.so
+ )
+
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install
}