diff options
author | Nicolas Iooss | 2024-02-21 13:23:35 +0100 |
---|---|---|
committer | Nicolas Iooss | 2024-02-21 13:23:35 +0100 |
commit | 152a3a035c5098c8be5cd15d179269d27de86ebe (patch) | |
tree | a8fd97842fd569d51551fdd1f24bf7c4bdd7121b | |
parent | e0e33b96c6d947822e2241aac9a861832a251f2e (diff) | |
download | aur-152a3a035c5098c8be5cd15d179269d27de86ebe.tar.gz |
Add 'provides' with the shared library
This helps making package depends on a precise major version of a shared
library.
-rw-r--r-- | .SRCINFO | 5 | ||||
-rw-r--r-- | PKGBUILD | 6 |
2 files changed, 8 insertions, 3 deletions
@@ -1,7 +1,7 @@ pkgbase = libsepol pkgdesc = SELinux binary policy manipulation library pkgver = 3.6 - pkgrel = 1 + pkgrel = 2 url = https://github.com/SELinuxProject/selinux arch = i686 arch = x86_64 @@ -11,7 +11,7 @@ pkgbase = libsepol license = LGPL2.1 makedepends = flex depends = glibc - provides = selinux-usr-libsepol=3.6-1 + provides = selinux-usr-libsepol=3.6-2 conflicts = selinux-usr-libsepol options = staticlibs options = !lto @@ -23,3 +23,4 @@ pkgbase = libsepol sha256sums = SKIP pkgname = libsepol + provides = libsepol.so @@ -8,7 +8,7 @@ pkgname=libsepol pkgver=3.6 -pkgrel=1 +pkgrel=2 pkgdesc="SELinux binary policy manipulation library" arch=('i686' 'x86_64' 'armv6h' 'aarch64') url='https://github.com/SELinuxProject/selinux' @@ -36,6 +36,10 @@ build() { } package() { + provides=( + libsepol.so + ) + cd "${pkgname}-${pkgver}" make DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install } |