summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2021-10-31 09:24:07 +0100
committerNicolas Iooss2021-10-31 09:24:07 +0100
commit9240291d19f0502c83e4c123ae392c02ade26d88 (patch)
tree62a7ad6f67650e24f28d9d940ac71517491ff02a
parentfdea1ee538511144f6d88e81c443a80056663b03 (diff)
downloadaur-9240291d19f0502c83e4c123ae392c02ade26d88.tar.gz
libsepol 3.3-1 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b58220fcbb22..6f041f7d429e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libsepol
pkgdesc = SELinux binary policy manipulation library
- pkgver = 3.2
+ pkgver = 3.3
pkgrel = 1
url = https://github.com/SELinuxProject/selinux
arch = i686
@@ -11,10 +11,10 @@ pkgbase = libsepol
license = LGPL2.1
makedepends = flex
depends = glibc
- provides = selinux-usr-libsepol=3.2-1
+ provides = selinux-usr-libsepol=3.3-1
conflicts = selinux-usr-libsepol
options = staticlibs
- source = https://github.com/SELinuxProject/selinux/releases/download/3.2/libsepol-3.2.tar.gz
- sha256sums = dfc7f662af8000116e56a01de6a0394ed79be1b34b999e551346233c5dd19508
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.3/libsepol-3.3.tar.gz
+ sha256sums = 2d97df3eb8466169b389c3660acbb90c54200ac96e452eca9f41a9639f4f238b
pkgname = libsepol
diff --git a/PKGBUILD b/PKGBUILD
index 09b8feeb237e..d259ecea3e31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libsepol
-pkgver=3.2
+pkgver=3.3
pkgrel=1
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'armv6h' 'aarch64')
@@ -20,22 +20,16 @@ options=(staticlibs)
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('dfc7f662af8000116e56a01de6a0394ed79be1b34b999e551346233c5dd19508')
+sha256sums=('2d97df3eb8466169b389c3660acbb90c54200ac96e452eca9f41a9639f4f238b')
build() {
cd "${pkgname}-${pkgver}"
export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make
-
- # Build a libsepol.so.1 to ease the transition from libsepol 3.1 to 3.2
- make -C src LIBVERSION=1 libsepol.so.1
- rm src/libsepol.so
}
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install
-
- install -Dm755 src/libsepol.so.1 "${pkgdir}/usr/lib"
}