summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-07-19 11:32:31 +0200
committerNicolas Iooss2020-07-19 11:32:31 +0200
commitb30bcf7e311514490442283b988b81389152b0ef (patch)
treef4b2eae043d60d44a02ff088120666102125d83d
parent66e234eaa4be6d2c15d5452016b9c92c22168e0c (diff)
downloadaur-b30bcf7e311514490442283b988b81389152b0ef.tar.gz
libsepol 3.1-1 update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aba30b76f383..947c8ae4c4c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = libsepol
pkgdesc = SELinux binary policy manipulation library
- pkgver = 3.0
- pkgrel = 2
- url = http://userspace.selinuxproject.org
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://github.com/SELinuxProject/selinux
arch = i686
arch = x86_64
arch = armv6h
groups = selinux
license = LGPL2.1
- makedepends = clang
makedepends = flex
depends = glibc
- provides = selinux-usr-libsepol=3.0-2
+ provides = selinux-usr-libsepol=3.1-1
conflicts = selinux-usr-libsepol
options = staticlibs
- source = https://github.com/SELinuxProject/selinux/releases/download/20191204/libsepol-3.0.tar.gz
- sha256sums = 5b7ae1881909f1048b06f7a0c364c5c8a86ec12e0ec76e740fe9595a6033eb79
+ source = https://github.com/SELinuxProject/selinux/releases/download/20200710/libsepol-3.1.tar.gz
+ sha256sums = ae6778d01443fdd38cd30eeee846494e19f4d407b09872580372f4aa4bf8a3cc
pkgname = libsepol
diff --git a/PKGBUILD b/PKGBUILD
index 84b2cb7da40e..ae4d20f92e82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,27 +7,29 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libsepol
-pkgver=3.0
-pkgrel=2
+pkgver=3.1
+pkgrel=1
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'armv6h')
-url='http://userspace.selinuxproject.org'
+url='https://github.com/SELinuxProject/selinux'
license=('LGPL2.1')
groups=('selinux')
-makedepends=('clang' 'flex')
+makedepends=('flex')
depends=('glibc')
options=(staticlibs)
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('5b7ae1881909f1048b06f7a0c364c5c8a86ec12e0ec76e740fe9595a6033eb79')
+source=("https://github.com/SELinuxProject/selinux/releases/download/20200710/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('ae6778d01443fdd38cd30eeee846494e19f4d407b09872580372f4aa4bf8a3cc')
build() {
cd "${pkgname}-${pkgver}"
- make CC=clang
+
+ export CFLAGS="${CFLAGS} -fno-semantic-interposition"
+ make
}
package() {
cd "${pkgname}-${pkgver}"
- make CC=clang DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install
+ make DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install
}