summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-05-26 18:41:54 +0200
committerNicolas Iooss2018-05-26 18:41:54 +0200
commitb5acb02e79ec91195a2b5ee2f27f09dbf602b177 (patch)
tree7b7c2d028055d3e94ab5b4f59391381b7b45cd5c
parentabcabfc6a98f82a936f0d444cf293d3ffa38e921 (diff)
downloadaur-b5acb02e79ec91195a2b5ee2f27f09dbf602b177.tar.gz
libsepol 2.8-1 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea469b51675a..fa76e0fa656a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libsepol
pkgdesc = SELinux binary policy manipulation library
- pkgver = 2.7
+ pkgver = 2.8
pkgrel = 1
url = http://userspace.selinuxproject.org
arch = i686
@@ -10,11 +10,11 @@ pkgbase = libsepol
license = LGPL2.1
makedepends = flex
depends = glibc
- provides = selinux-usr-libsepol=2.7-1
+ provides = selinux-usr-libsepol=2.8-1
conflicts = selinux-usr-libsepol
options = staticlibs
- source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/libsepol-2.7.tar.gz
- sha256sums = d69d3bd8ec901a3bd5adf2be2fb47fb1a685ed73066ab482e7e505371a48f9e7
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/libsepol-2.8.tar.gz
+ sha256sums = 3ad6916a8352bef0bad49acc8037a5f5b48c56f94e4cb4e1959ca475fa9d24d6
pkgname = libsepol
diff --git a/PKGBUILD b/PKGBUILD
index 6a1f456758ac..429a3631937c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,12 @@
# Contributor: Timothée Ravier <tim@siosm.fr>
# Contributor: Nicky726 (Nicky726 <at> gmail <dot> com)
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libsepol
-pkgver=2.7
+pkgver=2.8
pkgrel=1
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'armv6h')
@@ -16,8 +19,8 @@ depends=('glibc')
options=(staticlibs)
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('d69d3bd8ec901a3bd5adf2be2fb47fb1a685ed73066ab482e7e505371a48f9e7')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('3ad6916a8352bef0bad49acc8037a5f5b48c56f94e4cb4e1959ca475fa9d24d6')
build() {
cd "${pkgname}-${pkgver}"
@@ -26,5 +29,5 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" SHLIBDIR="${pkgdir}"/usr/lib install
+ make DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install
}