summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2021-03-10 11:45:50 +0100
committerNicolas Iooss2021-03-10 11:45:50 +0100
commitc7ea8464da00113e819ce7534da8c01f9e580d31 (patch)
tree8524d240b06b295f5df7a2a655b2ad7fc3a5d4f6
parentb30bcf7e311514490442283b988b81389152b0ef (diff)
downloadaur-c7ea8464da00113e819ce7534da8c01f9e580d31.tar.gz
libsepol 3.2-1 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 947c8ae4c4c8..935b8c888d28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libsepol
pkgdesc = SELinux binary policy manipulation library
- pkgver = 3.1
+ pkgver = 3.2
pkgrel = 1
url = https://github.com/SELinuxProject/selinux
arch = i686
@@ -10,11 +10,11 @@ pkgbase = libsepol
license = LGPL2.1
makedepends = flex
depends = glibc
- provides = selinux-usr-libsepol=3.1-1
+ provides = selinux-usr-libsepol=3.2-1
conflicts = selinux-usr-libsepol
options = staticlibs
- source = https://github.com/SELinuxProject/selinux/releases/download/20200710/libsepol-3.1.tar.gz
- sha256sums = ae6778d01443fdd38cd30eeee846494e19f4d407b09872580372f4aa4bf8a3cc
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.2/libsepol-3.2.tar.gz
+ sha256sums = dfc7f662af8000116e56a01de6a0394ed79be1b34b999e551346233c5dd19508
pkgname = libsepol
diff --git a/PKGBUILD b/PKGBUILD
index ae4d20f92e82..600ef68d016c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libsepol
-pkgver=3.1
+pkgver=3.2
pkgrel=1
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'armv6h')
@@ -19,17 +19,23 @@ depends=('glibc')
options=(staticlibs)
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20200710/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('ae6778d01443fdd38cd30eeee846494e19f4d407b09872580372f4aa4bf8a3cc')
+source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('dfc7f662af8000116e56a01de6a0394ed79be1b34b999e551346233c5dd19508')
build() {
cd "${pkgname}-${pkgver}"
export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make
+
+ # Build a libsepol.so.1 to ease the transition from libsepol 3.1 to 3.2
+ make -C src LIBVERSION=1 libsepol.so.1
+ rm src/libsepol.so
}
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install
+
+ install -Dm755 src/libsepol.so.1 "${pkgdir}/usr/lib"
}