summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcgugas2018-03-08 12:11:22 -0600
committercgugas2018-03-08 12:11:22 -0600
commit362af5fbe9bbcf53ee9d47d6eac6878bbf5746f5 (patch)
tree2fc8520627c6f61ac2cb0d5da877e5179fdfcfa1
parent7ba555c841a1360bff4deb9adb761a7d28fa52ad (diff)
downloadaur-362af5fbe9bbcf53ee9d47d6eac6878bbf5746f5.tar.gz
updated PKGBUILD
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6c81ade063c..0f1da4b19502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
+# Maintainer: CountMurphy <spartan1086@gmail.com>
# Maintainer: Shelvacu <aur@shelvacu.com>
_gitname=libserial
pkgname="${_gitname}-git"
-pkgver=r148.80e5f25
+pkgver=r168.1201211
pkgrel=1
pkgdesc="A library for accessing serial ports on POSIX systems (git version)"
arch=('x86_64')
url="https://github.com/crayzeewulf/${_gitname}/"
license=('GPL2')
-makedepends=('git' 'python2-sip')
+makedepends=('git' 'python2-sip' 'gtest')
conflicts=("${_gitname}")
provides=("${_gitname}")
source=("$pkgname"::"git+https://github.com/crayzeewulf/${_gitname}.git")
@@ -22,19 +23,12 @@ pkgver() {
build() {
cd "$pkgname"
- make -f Makefile.dist
-
- ./configure --prefix=/usr
-
- cd sip
- python2 configure.py #Workaround from https://github.com/crayzeewulf/libserial/issues/62
- cd ..
-
- make
+ sed -i '1i#!/usr/bin/bash' compile.sh
+ ./compile.sh
}
package() {
cd "$pkgname"
-
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ mkdir -p $pkgdir/usr/lib
+ install -Dm555 build/lib/libserial.so "$pkgdir/usr/lib/"
}