summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2019-12-22 16:06:40 +0000
committerWill Handley2019-12-22 16:06:40 +0000
commit3f843a8395366ee8dc5b002782c6d2e682412ace (patch)
tree50076dde0a78cb53ffca1fb42d8c68c3e9d2b8a9
downloadaur-3f843a8395366ee8dc5b002782c6d2e682412ace.tar.gz
version 1.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29b8cd96af79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libsharp
+ pkgdesc = Library for fast spherical harmonic transforms, see http://arxiv.org/abs/1303.4945
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Libsharp/libsharp
+ arch = any
+ license = GPLv2
+ options = !emptydirs
+ source = https://github.com/Libsharp/libsharp/archive/v1.0.0.tar.gz
+ sha256sums = ca7cc7790c98bd5637a8a3d84460c02a54e5132b3184e713e596cd70c3cd59c0
+
+pkgname = libsharp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3b8986b7c2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=libsharp
+pkgver='1.0.0'
+pkgrel=1
+pkgdesc="Library for fast spherical harmonic transforms, see http://arxiv.org/abs/1303.4945"
+arch=(any)
+url="https://github.com/Libsharp/libsharp"
+license=('GPLv2')
+groups=()
+depends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('ca7cc7790c98bd5637a8a3d84460c02a54e5132b3184e713e596cd70c3cd59c0')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ autoconf
+ ./configure --prefix="${pkgdir}/usr"
+ make -j
+}
+
+package() {
+ mkdir ${pkgdir}/usr
+ cp -r "${srcdir}/${pkgname}-${pkgver}/auto/"* ${pkgdir}/usr
+}
+