summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Savannah2018-07-24 23:34:33 -0400
committerTim Savannah2018-07-24 23:34:33 -0400
commit58fddd70f6ff1e09562f8f6801fddcf33e3d3ca3 (patch)
tree64e42b78455268e21076598b8f60fe82e04710ee
downloadaur-58fddd70f6ff1e09562f8f6801fddcf33e3d3ca3.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..384adc849879
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libshmfile
+ pkgdesc = Small shared library to use shared memory as a FILE* stream , with interprocess communication in mind
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://github.com/kata198/shmfile
+ arch = i686
+ arch = x86_64
+ license = apache
+ makedepends = gcc
+ makedepends = make
+ depends = glibc
+ source = https://github.com/kata198/shmfile/archive/1.0.0.tar.gz
+ sha512sums = 2fffa65f514ee10f713b940d87f1c58c2a2a9388c6d62f4f7304537e1cfdfbcffe3c7db187a6f78cc8a315f9e227897b18ac2614a27310b9ad3dce4ecf2a7729
+
+pkgname = libshmfile
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6184db34473
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.*
+src/
+pkg/
+*.sw[po]
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a48a10ebc92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tim Savannah <kata198@gmail.com>
+
+pkgname=libshmfile
+_basename="shmfile"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Small shared library to use shared memory as a FILE* stream , with interprocess communication in mind"
+arch=('i686' 'x86_64')
+license=('apache')
+url="http://github.com/kata198/shmfile"
+makedepends=('gcc' 'make')
+depends=('glibc')
+source=("https://github.com/kata198/${_basename}/archive/${pkgver}.tar.gz")
+sha512sums=("2fffa65f514ee10f713b940d87f1c58c2a2a9388c6d62f4f7304537e1cfdfbcffe3c7db187a6f78cc8a315f9e227897b18ac2614a27310b9ad3dce4ecf2a7729")
+
+build() {
+ cd "${srcdir}/${_basename}-${pkgver}"
+
+ make CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ # Build and install static libs. If options has !staticlibs
+ # set in /etc/makepkg.conf, the static lib will be removed
+ # during packaging.
+ make CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" static
+
+}
+
+package() {
+ cd "${srcdir}/${_basename}-${pkgver}"
+
+ make install DESTDIR="${pkgdir}"
+ make install_static DESTDIR="${pkgdir}"
+}