summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-09-06 10:57:43 -0600
committerMark Wagie2022-09-06 10:57:43 -0600
commit3973728a574d950c5e417b9769fdec66ea2b3eee (patch)
tree1325dc3ae385b767059be29b1deea22b21a15423
parentd733e0963a2d8283ef505a05cd75428d9ab54227 (diff)
downloadaur-3973728a574d950c5e417b9769fdec66ea2b3eee.tar.gz
update deps, PKGBUILD improvements
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD45
3 files changed, 28 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c069d7c10deb..8fffc4ceb0a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,23 @@
pkgbase = libshumate-git
- pkgdesc = GTK4 widget to display maps (git version)
+ pkgdesc = GTK toolkit providing widgets for embedded maps
pkgver = 1.0.0.beta.r6.g125757b
pkgrel = 1
url = https://wiki.gnome.org/Projects/libshumate
arch = x86_64
arch = aarch64
license = LGPL
- checkdepends = xorg-server-xvfb
+ makedepends = gi-docgen
makedepends = git
makedepends = gobject-introspection
makedepends = gtk-doc
- makedepends = gi-docgen
makedepends = meson
makedepends = vala
depends = gtk4
- depends = libsoup
+ depends = libsoup3
depends = sqlite
- depends = protobuf-c
provides = libshumate
- provides = libshumate-1.0.so=1-64
+ provides = libshumate-1.0.so=1
conflicts = libshumate
- conflicts = libshumate-1.0.so=1-64
source = git+https://gitlab.gnome.org/GNOME/libshumate.git
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index e7e5780e39ac..0f6e42529426 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,33 @@
-# Maintainer: Triss Healy (trissylegs) <th at trissyle dot gs>
-
-_pkgname=libshumate
-pkgname=${_pkgname}-git
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Triss Healy (trissylegs) <th at trissyle dot gs>
+pkgname=libshumate-git
pkgver=1.0.0.beta.r6.g125757b
pkgrel=1
-pkgdesc="GTK4 widget to display maps (git version)"
-arch=(x86_64 aarch64)
+pkgdesc="GTK toolkit providing widgets for embedded maps"
+arch=('x86_64' 'aarch64')
url="https://wiki.gnome.org/Projects/libshumate"
-license=(LGPL)
-depends=(gtk4 libsoup sqlite protobuf-c)
-makedepends=(git gobject-introspection gtk-doc gi-docgen meson vala)
-checkdepends=(xorg-server-xvfb)
-provides=(libshumate libshumate-1.0.so=1-64)
-conflicts=(libshumate libshumate-1.0.so=1-64)
-source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git")
+license=('LGPL')
+depends=('gtk4' 'libsoup3' 'sqlite')
+makedepends=('gi-docgen' 'git' 'gobject-introspection' 'gtk-doc' 'meson' 'vala')
+provides=("${pkgname%-git}" "${pkgname%-git}-1.0.so=1")
+conflicts=("${pkgname%-git}")
+source=("git+https://gitlab.gnome.org/GNOME/libshumate.git")
sha256sums=('SKIP')
-# Use version once repo has been tagged. But use revision numbers for now.
pkgver() {
- cd "${_pkgname}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson ${_pkgname} build -D gtk_doc=true
- ninja -C build
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
}
check() {
- # Make a Empty $XDG_CONFIG_DIR to prevent issues to user
- # customization breaking tests
- mkdir -p $srcdir/test_config_dir
-
- # Run tests with headless x11 server.
- env \
- XDG_CONFIG_DIR=$srcdir/test_config_dir \
- XDG_CONFIG_HOME=$srcdir/test_config_dir \
- xvfb-run meson test -C build --print-errorlogs
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}