summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTriss Healy2022-01-15 13:09:00 +1100
committerTriss Healy2022-01-15 13:09:00 +1100
commita1225b94779155922f82256699d1389e52f7118e (patch)
treed9bec8f7a66ec425e81c1fa226ffc6441382fd64
parent767c2a9ba88f4be25f0d81b90344b3dcd610e9c3 (diff)
downloadaur-a1225b94779155922f82256699d1389e52f7118e.tar.gz
Updated to version 1.0.0.alpha.1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e75879ffdb50..a9f727cb3c93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libshumate-git
pkgdesc = GTK4 widget to display maps (git version)
- pkgver = r270.5c08c3a
+ pkgver = 1.0.0.alpha.1.r1.g4804d64
pkgrel = 1
url = https://wiki.gnome.org/Projects/libshumate
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6a6d12adb55c..848a0d74473c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=libshumate
pkgname=${_pkgname}-git
-pkgver=r270.5c08c3a
+pkgver=1.0.0.alpha.1.r1.g4804d64
pkgrel=1
pkgdesc="GTK4 widget to display maps (git version)"
arch=(x86_64)
@@ -19,17 +19,16 @@ sha256sums=('SKIP')
# Use version once repo has been tagged. But use revision numbers for now.
pkgver() {
cd "${_pkgname}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+
build() {
arch-meson ${_pkgname} build -D gtk_doc=true
ninja -C build
}
+
check() {
# Run tests with headless x11 server.
xvfb-run meson test -C build --print-errorlogs