summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTriss Healy2021-07-14 21:50:08 +1000
committerTriss Healy2021-07-14 21:50:08 +1000
commitd06742b234a7208d369cb916ca657a5a427a8c8f (patch)
tree77c3ad33a6dbef3a38bfe96f507781ee432f71a9
downloadaur-d06742b234a7208d369cb916ca657a5a427a8c8f.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3185d3bbec84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libshumate-git
+ pkgdesc = GTK4 widget to display maps (git version)
+ pkgver = 0.0
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/libshumate
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = gi-docgen
+ makedepends = meson
+ makedepends = vala
+ depends = gtk4
+ depends = libsoup
+ depends = sqlite
+ provides = libshumate
+ provides = libshumate-0.0.so
+ source = git+https://gitlab.gnome.org/GNOME/libshumate.git
+ sha256sums = SKIP
+
+pkgname = libshumate-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3324fe64ecb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Triss Healy (trissylegs) <th at trissyle dot gs>
+
+pkgname=libshumate-git
+pkgver=0.0
+pkgrel=1
+pkgdesc="GTK4 widget to display maps (git version)"
+arch=(x86_64)
+url="https://wiki.gnome.org/Projects/libshumate"
+license=(LGPL)
+depends=(gtk4 libsoup sqlite)
+makedepends=(git gobject-introspection gtk-doc gi-docgen meson vala)
+provides=("libshumate" "libshumate-${pkgver}.so")
+
+source=("git+https://gitlab.gnome.org/GNOME/${pkgname/-git/}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ # Read version number from meson file.
+ grep -oP "(?<=version: ')\d+\.\d+" ${pkgname/-git/}/meson.build
+}
+
+prepare() {
+ cd ${pkgname/-git/}
+}
+
+build() {
+ arch-meson ${pkgname/-git/} build -D gtk_doc=true
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}