summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:48:27 -0700
committerAnatol Pomozov2015-06-17 08:48:27 -0700
commit131fd8c8d0aa3bd79465afb855a396ac30e76efd (patch)
treec9067a515b6599fbc350787dfe66cf3b4c7138b2
downloadaur-131fd8c8d0aa3bd79465afb855a396ac30e76efd.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2531300b5b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libsigrok4dsl-git
+ pkgdesc = A library which provides the basic API for DreamSourceLab hardware
+ pkgver = r66.71d0f5a
+ pkgrel = 1
+ url = https://github.com/DreamSourceLab/DSView
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = libzip
+ depends = libusb
+ depends = libserialport
+ source = git://github.com/DreamSourceLab/DSView.git
+ sha1sums = SKIP
+
+pkgname = libsigrok4dsl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1805a712811c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=libsigrok4dsl-git
+pkgver=r66.71d0f5a
+pkgrel=1
+pkgdesc='A library which provides the basic API for DreamSourceLab hardware'
+url='https://github.com/DreamSourceLab/DSView'
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(libzip libusb libserialport)
+makedepends=(git)
+source=(git://github.com/DreamSourceLab/DSView.git)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd DSView
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd DSView/libsigrok4DSL
+ ./autogen.sh
+
+ # remove rpath
+ sed 's| -Wl,--rpath=/usr/local/lib||' -i configure.ac
+ autoconf
+}
+
+build() {
+ cd DSView/libsigrok4DSL
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd DSView/libsigrok4DSL
+ make install DESTDIR="$pkgdir"
+}