summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2021-09-18 13:48:39 +0200
committerBrainDamage2021-09-18 13:48:39 +0200
commit0407cc35f60f01e92ae84c0ece46fc86f36be5ee (patch)
treee719c65c76536fc461a2f8cfc3d104429ddc2044
parent4b1026731dcb9f09835b54fc46d3d706ebbcaba5 (diff)
downloadaur-0407cc35f60f01e92ae84c0ece46fc86f36be5ee.tar.gz
version bump
updated build system to meson since upstream deprecated autotools added gdk-pixbuf2 to the deps added meson to build deps fixed version to adhere more closely to the guidelines, upstream itself dropped the 'v' except in the release title
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5f72ada0ded..ef0956284a1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = libsixel
pkgdesc = provides a codec for DEC SIXEL graphics, and some converter programs
- pkgver = v1.9.0
+ pkgver = 1.10.1
pkgrel = 1
url = https://github.com/libsixel/libsixel
arch = i686
arch = x86_64
license = MIT
+ makedepends = meson
depends = libjpeg-turbo
depends = libpng
depends = python
depends = curl
- source = https://github.com/libsixel/libsixel/archive/v1.9.0.tar.gz
- sha256sums = f39a32a8a6e9f952941319fb421e10287cd2c954f2f69e416b0b20445c67496c
+ depends = gdk-pixbuf2
+ source = https://github.com/libsixel/libsixel/archive/v1.10.1.tar.gz
+ sha256sums = 67032a0b9c5a1022308710eb863489dfb9ef685d222106bd8d3e4a3aafa2855c
pkgname = libsixel
diff --git a/PKGBUILD b/PKGBUILD
index dc996717425d..d32f229a10e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
# Maintainer: BrainDamage
pkgname="libsixel"
pkgrel=1
-pkgver="v1.9.0"
+pkgver="1.10.1"
pkgdesc="provides a codec for DEC SIXEL graphics, and some converter programs"
arch=("i686" "x86_64")
url="https://github.com/libsixel/libsixel"
license=("MIT")
-depends=("libjpeg-turbo" "libpng" "python" "curl")
-sha256sums=('f39a32a8a6e9f952941319fb421e10287cd2c954f2f69e416b0b20445c67496c')
-source=("https://github.com/libsixel/libsixel/archive/${pkgver}.tar.gz")
+depends=("libjpeg-turbo" "libpng" "python" "curl" "gdk-pixbuf2")
+makedepends=("meson")
+sha256sums=('67032a0b9c5a1022308710eb863489dfb9ef685d222106bd8d3e4a3aafa2855c')
+source=("https://github.com/libsixel/libsixel/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver#v}"
- ./configure --prefix=/usr --enable-python --enable-tests
- make
+ meson --prefix=/usr --buildtype=plain -Dtests=enabled -Dlibcurl=enabled -Dgdk-pixbuf2=enabled "${srcdir}/${pkgname}-${pkgver}" build
+ meson compile -C build
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver#v}"
- make test
+ meson test -C build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver#v}"
- make DESTDIR="${pkgdir}" install
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/libsixel/LICENSE"
+ meson install -C build --destdir "${pkgdir}"
+ install -Dm 644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/libsixel/LICENSE"
}