summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2016-10-04 19:39:04 +0200
committerBrainDamage2016-10-04 19:39:04 +0200
commit307536575b8c173f81433be6f78504483bacc616 (patch)
treecb9c537c423c14055365679a5589599ab06a22b4
downloadaur-307536575b8c173f81433be6f78504483bacc616.tar.gz
initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b47b18c3c2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libsixel
+ pkgdesc = libsixel provides and encoder/decoder implementation for DEC SIXEL graphics, and some converter programs
+ pkgver = v1.7.2
+ pkgrel = 1
+ url = https://saitoha.github.io/libsixel/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = python
+ depends = curl
+ source = https://github.com/saitoha/libsixel/archive/v1.7.2.tar.gz
+ sha1sums = e6f7a745f5c7675f8abaaae3a28b8780567de49a
+
+pkgname = libsixel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa465dd12719
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: BrainDamage
+pkgname="libsixel"
+pkgrel=1
+stripped_ver="1.7.2"
+pkgver="v$stripped_ver"
+pkgdesc="libsixel provides and encoder/decoder implementation for DEC SIXEL graphics, and some converter programs"
+arch=("i686" "x86_64")
+url="https://saitoha.github.io/libsixel/"
+license=("MIT")
+depends=("libjpeg-turbo" "libpng" "python" "curl")
+sha1sums=("e6f7a745f5c7675f8abaaae3a28b8780567de49a")
+source=("https://github.com/saitoha/libsixel/archive/$pkgver.tar.gz")
+
+build() {
+ cd "libsixel-$stripped_ver"
+ ./configure --prefix=/usr --enable-python
+}
+
+package() {
+ cd "libsixel-$stripped_ver"
+ make DESTDIR="$pkgdir" install
+}