summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhalosghost2015-08-02 12:47:36 -0500
committerhalosghost2015-08-02 12:47:36 -0500
commite5428d32f0d9296e6e1dfe4d42395c301c991c8c (patch)
tree4e24816b9d53b614d4d56cfac79b3225e7bda9d8
downloadaur-e5428d32f0d9296e6e1dfe4d42395c301c991c8c.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..498efc57b8cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libsixel-git
+ pkgdesc = A lightweight, fast implementation of DEC SIXEL graphics codec
+ pkgver = r1938.8849016
+ pkgrel = 1
+ url = https://github.com/saitoha/libsixel
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = curl
+ depends = libjpeg-turbo
+ depends = libpng
+ source = git+https://github.com/saitoha/libsixel
+ sha256sums = SKIP
+
+pkgname = libsixel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..149ab71e6b16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+pkgname=libsixel-git
+pkgver=r1938.8849016
+pkgrel=1
+pkgdesc='A lightweight, fast implementation of DEC SIXEL graphics codec'
+arch=('x86_64' 'i686')
+url='https://github.com/saitoha/libsixel'
+license=('MIT')
+depends=('curl' 'libjpeg-turbo' 'libpng')
+
+source=("git+https://github.com/saitoha/libsixel")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "libsixel"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "libsixel"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "libsixel"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}