summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-07 20:17:22 +0100
committerJosef Miegl2019-02-07 20:17:22 +0100
commit6c3fe545f6c2a0053757a03068dfbf0fb2b633a5 (patch)
treefe87fb2617de7778e9154d778d1b2b4c9e09bd22
parentb3a881c40bcd15fbde8292a138d9486710534721 (diff)
downloadaur-6c3fe545f6c2a0053757a03068dfbf0fb2b633a5.tar.gz
add makedepends, style
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 23 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b3e9d373175..891598ba1450 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = libsmpp34-git
- pkgdesc = This is the Osmocom version of libsmpp34, an implementation of the SMPP Protocol v3.4
+ pkgdesc = Osmocom version of libsmpp34, an implementation of the SMPP Protocol v3.4
pkgver = 1.13.0.3.g3cf5229
pkgrel = 1
url = http://osmocom.org/projects/libsmpp34
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
license = GPL
+ makedepends = git
depends = libosmocore
provides = libsmpp34
conflicts = libsmpp34
- source = git://git.osmocom.org/libsmpp34
+ source = git+https://git.osmocom.org/libsmpp34
sha256sums = SKIP
pkgname = libsmpp34-git
diff --git a/PKGBUILD b/PKGBUILD
index e42d24a19dfd..91d03ac511e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,34 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
pkgname=libsmpp34-git
-_pkgname=libsmpp34
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
pkgver=1.13.0.3.g3cf5229
pkgrel=1
-pkgdesc="This is the Osmocom version of libsmpp34, an implementation of the SMPP Protocol v3.4"
+pkgdesc="Osmocom version of libsmpp34, an implementation of the SMPP Protocol v3.4"
url="http://osmocom.org/projects/libsmpp34"
-arch=('any')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
depends=('libosmocore')
-source=("git://git.osmocom.org/${_pkgname}")
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://git.osmocom.org/${pkgname%-git}")
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
- echo $(git describe --always | sed 's/-/./g')
+ cd "${srcdir}/${pkgname%-git}"
+ echo $(git describe --always | sed 's/-/./g')
}
build() {
- cd "${srcdir}/${_pkgname}"
- autoreconf -i
- ./configure --prefix=/usr
- make
+ cd "${srcdir}/${pkgname%-git}"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/${_pkgname}"
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname%-git}"
+ make DESTDIR=${pkgdir} install
}
+
+# vim:set ts=2 sw=2 et: