summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-06 18:10:04 +0100
committerJosef Miegl2019-02-06 18:10:04 +0100
commitb3a881c40bcd15fbde8292a138d9486710534721 (patch)
tree3353fe171788c98ea362f0826490d24428d93061
downloadaur-b3a881c40bcd15fbde8292a138d9486710534721.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b3e9d373175
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libsmpp34-git
+ pkgdesc = This is the Osmocom version of libsmpp34, an implementation of the SMPP Protocol v3.4
+ pkgver = 1.13.0.3.g3cf5229
+ pkgrel = 1
+ url = http://osmocom.org/projects/libsmpp34
+ arch = any
+ license = GPL
+ depends = libosmocore
+ provides = libsmpp34
+ conflicts = libsmpp34
+ source = git://git.osmocom.org/libsmpp34
+ sha256sums = SKIP
+
+pkgname = libsmpp34-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e42d24a19dfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Josef Miegl <josef@miegl.cz>
+
+pkgname=libsmpp34-git
+_pkgname=libsmpp34
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+pkgver=1.13.0.3.g3cf5229
+pkgrel=1
+pkgdesc="This is the Osmocom version of libsmpp34, an implementation of the SMPP Protocol v3.4"
+url="http://osmocom.org/projects/libsmpp34"
+arch=('any')
+license=(GPL)
+depends=('libosmocore')
+source=("git://git.osmocom.org/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR=${pkgdir} install
+}