summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-01-10 15:40:54 -0800
committerAndy Weidenbaum2016-01-10 15:40:54 -0800
commit324914885ea4070a4d484044099674c1429c3c0c (patch)
tree8a8cb0362c875fbd71d14eabf729c6d4a3bdb60f
downloadaur-324914885ea4070a4d484044099674c1429c3c0c.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD53
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a68a7cd6e1a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sun Jan 10 23:40:50 UTC 2016
+pkgbase = libsnappy
+ pkgdesc = A fast compressor/decompressor
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://google.github.io/snappy/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = git
+ makedepends = libtool
+ makedepends = m4
+ makedepends = make
+ makedepends = pkg-config
+ provides = snappy
+ conflicts = snappy
+ source = libsnappy-1.1.3::git+https://github.com/google/snappy
+ source = pkg-config.diff::https://github.com/deviance/snappy/commit/d2cb73b6ac1839462fcea926c7e73d1e627bd699.diff
+ sha256sums = SKIP
+ sha256sums = 596a9246a24822cd83abaa88ca3846fbaa1d50b5dcc4ebe23bf29ff2e19241d8
+
+pkgname = libsnappy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f084e5bb4d8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Antony Male <antony dot male at geemail dot com>>
+
+pkgname=libsnappy
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="A fast compressor/decompressor"
+arch=('i686' 'x86_64')
+makedepends=('autoconf' 'automake' 'git' 'libtool' 'm4' 'make' 'pkg-config')
+url="https://google.github.io/snappy/"
+license=('BSD')
+source=($pkgname-$pkgver::git+https://github.com/google/snappy
+ pkg-config.diff::https://github.com/deviance/snappy/commit/d2cb73b6ac1839462fcea926c7e73d1e627bd699.diff)
+sha256sums=('SKIP'
+ '596a9246a24822cd83abaa88ca3846fbaa1d50b5dcc4ebe23bf29ff2e19241d8')
+provides=('snappy')
+conflicts=('snappy')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Fixing pkg-config...'
+ git apply "$srcdir/pkg-config.diff"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Building...'
+ # compile without assertions
+ export CXXFLAGS+=\ -DNDEBUG
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/snappy \
+ --sysconfdir=/etc \
+ --sharedstatedir=/usr/share/snappy \
+ --localstatedir=/var/lib/snappy \
+ --with-gnu-ld
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 COPYING -t "$pkgdir/usr/share/licenses/libsnappy"
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" install
+}