summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex J. Malozemoff2018-10-22 15:01:36 -0700
committerAlex J. Malozemoff2018-10-22 15:01:36 -0700
commitee9aa01c542aee12f16913c30e95f7aabb75869c (patch)
treeb29cc807dcca15488dfe99baf9b9b2610f5a7003
downloadaur-ee9aa01c542aee12f16913c30e95f7aabb75869c.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7153deba7f7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libsnark-git
+ pkgdesc = libsnark: a C++ library for zkSNARK proofs
+ pkgver = v20140603.r321.g3e92af1
+ pkgrel = 1
+ url = https://github.com/scipr-lab/libsnark
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = gmp
+ provides = libsnark
+ source = git+https://github.com/scipr-lab/libsnark.git
+ sha1sums = SKIP
+
+pkgname = libsnark-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5794f6b1d120
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+libsnark/
+pkg/
+src/
+*.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8788e74b1308
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
+pkgname=libsnark-git
+_pkgname=libsnark
+pkgver=v20140603.r321.g3e92af1
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+pkgrel=1
+pkgdesc="libsnark: a C++ library for zkSNARK proofs"
+arch=('i686' 'x86_64')
+url="https://github.com/scipr-lab/libsnark"
+license=('MIT')
+depends=('gmp')
+makedepends=('cmake')
+provides=('libsnark')
+source=("git+https://github.com/scipr-lab/libsnark.git")
+sha1sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ git submodule update --init
+ cmake .
+ make
+}
+
+check() {
+ cd "$srcdir/$_pkgname"
+
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}