summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatthias gatto2018-12-15 09:44:08 +0100
committermatthias gatto2018-12-15 09:44:08 +0100
commit48b8b5c96015158ee64b9b0cc60354fe0db078c0 (patch)
treee3126a78f15be18e2361a6220822ccdf71b069e6
downloadaur-48b8b5c96015158ee64b9b0cc60354fe0db078c0.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..485806a7b0ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libsndio-61-compat
+ pkgdesc = A small audio and MIDI framework part of the OpenBSD project
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = http://www.sndio.org
+ arch = x86_64
+ license = ISC
+ depends = alsa-lib
+ depends = libbsd
+ source = http://www.sndio.org/sndio-1.3.0.tar.gz
+ sha256sums = bcc33213f02adc71bd0c3543f3b243847e7d27c5243b0b558182bc1b3056e4b1
+
+pkgname = libsndio-61-compat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..796e33063b77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Matthias gatto <uso.cosmo.ray@gmail.com>
+# Form from original sndio package from : Ivy Foster <code@escondida.tk>
+# Reference: PKGBUILD(5)
+
+pkgname=libsndio-61-compat
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='A small audio and MIDI framework part of the OpenBSD project'
+arch=(x86_64)
+url='http://www.sndio.org'
+license=(ISC)
+
+# sndio can be built without libbsd, but there are a bunch of individual
+# ISC-licensed files by different authors to extract the licenses from
+# if done that way. Licenses are complicated.
+depends=(alsa-lib libbsd)
+
+source=("http://www.sndio.org/sndio-$pkgver.tar.gz")
+# checksums provided by packager
+sha256sums=(bcc33213f02adc71bd0c3543f3b243847e7d27c5243b0b558182bc1b3056e4b1)
+# backup=(etc/default/sndiod)
+
+build() {
+ cd "sndio-$pkgver"
+ ./configure --enable-alsa --with-libbsd
+ make
+}
+
+package() {
+ cd "sndio-$pkgver"
+
+ install -D -m 755 libsndio/libsndio.so.6.1 \
+ "$pkgdir/usr/lib/libsndio.so.6.1"
+}