summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorssharunas2017-03-20 19:56:21 +0200
committerssharunas2017-03-20 19:56:21 +0200
commitb289dec708163745523492d4b508717165379481 (patch)
tree93338d949bc7a9c16c2ac5702ec2cc599c06ec3f
downloadaur-b289dec708163745523492d4b508717165379481.tar.gz
Initial commit.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..366e511b8fbe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libsoc-git
+ pkgdesc = libsoc is a C library to interface with common peripherals found in System on Chips (SoC) through generic Linux Kernel interfaces.
+ pkgver = 0.8.2.r17.g5b788d4
+ pkgrel = 1
+ url = https://github.com/jackmitch/libsoc
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = autoconf
+ source = git://github.com/jackmitch/libsoc.git
+ sha256sums = SKIP
+
+pkgname = libsoc-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a823c8b1fdd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Šarūnas Gliebus <ssharunas at yahoo.co.uk>
+
+pkgname=libsoc-git
+pkgver=0.8.2.r17.g5b788d4
+pkgrel=1
+pkgdesc="libsoc is a C library to interface with common peripherals found in System on Chips (SoC) through generic Linux Kernel interfaces."
+arch=('any')
+url="https://github.com/jackmitch/libsoc"
+license=('GPL')
+makedepends=('git' 'autoconf')
+source=(git://github.com/jackmitch/libsoc.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/libsoc"
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd "$srcdir/libsoc"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/libsoc"
+ make DESTDIR="$pkgdir/" install
+}