summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlie Sale2018-10-20 19:06:48 -0500
committerCharlie Sale2018-10-21 13:31:00 -0500
commit75dd249d720b4933db55f18100aacb3813b6cdea (patch)
tree971f3ab574e724530caae5ee57a1018b0b540647
downloadaur-libsocketpp.tar.gz
Version 1.0 release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39fbc3ae5826
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libsocketpp
+ pkgdesc = A modern C++ library for sockets
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/softwaresale/libsocketpp
+ arch = x86_64
+ license = GPL
+ depends = gcc
+ depends = autoconf
+ depends = automake
+ depends = libtool
+ source = https://github.com/softwaresale/libsocketpp/releases/download/1.0/libsocketpp-1.0.tar.gz
+ sha256sums = b12580699a8432ba51f67894766d6d6212dd32d5eae296ff6bf51cd40862ff00
+
+pkgname = libsocketpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4267f11cc29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Charlie Sale <softwaresale01@gmail.com>
+pkgname=libsocketpp
+pkgver=1.0
+pkgrel=1
+pkgdesc="A modern C++ library for sockets"
+arch=(x86_64)
+url="https://github.com/softwaresale/libsocketpp"
+license=('GPL')
+groups=()
+depends=(gcc autoconf automake libtool)
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/softwaresale/libsocketpp/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
+noextract=()
+sha256sums=('b12580699a8432ba51f67894766d6d6212dd32d5eae296ff6bf51cd40862ff00')
+#autofill using updpkgsums
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+ make check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}