summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoohbah2015-07-06 21:25:35 +0000
committerBoohbah2015-07-06 21:25:35 +0000
commitb1655b736b7bc26b6ba276cbb565b86207c7b067 (patch)
treefe855f41eb28da71bd7d0b4da6a299adefb8af2e
downloadaur-b1655b736b7bc26b6ba276cbb565b86207c7b067.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc63d9728b21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libsodium-git
+ pkgdesc = P(ortable|ackageable) NaCl-based crypto library (git version)
+ pkgver = 1.0.2.r65.g6ab4589
+ pkgrel = 1
+ url = https://github.com/jedisct1/libsodium
+ arch = i686
+ arch = x86_64
+ license = ISC
+ makedepends = git
+ provides = libsodium
+ conflicts = libsodium
+ source = libsodium-git::git+https://github.com/jedisct1/libsodium.git
+ md5sums = SKIP
+
+pkgname = libsodium-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21386f4927fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Boohbah <boohbah at gmail.com>
+# Contributor: sekret <sekret at posteo.se>
+
+pkgname=libsodium-git
+pkgver=1.0.2.r65.g6ab4589
+pkgrel=1
+pkgdesc="P(ortable|ackageable) NaCl-based crypto library (git version)"
+arch=('i686' 'x86_64')
+url="https://github.com/jedisct1/libsodium"
+license=('ISC')
+makedepends=('git')
+conflicts=('libsodium')
+provides=('libsodium')
+source=("$pkgname::git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ sh autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "$pkgname"
+ make check
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set sts=2 sw=2 et: