summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Menelkir2023-11-06 14:15:22 -0300
committerDaniel Menelkir2023-11-06 14:15:22 -0300
commit894b98d9fe4affb99ce860ddf060cafbbdbcc83a (patch)
tree0c16ef0bc25748e3b238f7ef06e5fad2cc2b2cbb
downloadaur-894b98d9fe4affb99ce860ddf060cafbbdbcc83a.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c59f92dde0fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libspectrum-git
+ pkgdesc = ZX Spectrum emulator support library.
+ pkgver = 1.6.0.1ec4c7
+ pkgrel = 1
+ url = http://fuse-emulator.sourceforge.net/libspectrum.php
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libgcrypt
+ depends = glib2
+ depends = audiofile
+ conflicts = libspectrum
+ source = libspectrum::git+https://git.code.sf.net/p/fuse-emulator/libspectrum
+ md5sums = SKIP
+
+pkgname = libspectrum-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65c597dec837
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Daniel Menelkir <dmenelkir at gmail dot com>
+
+pkgname=libspectrum-git
+pkgver=1.6.0.1ec4c7
+pkgrel=1
+pkgdesc="ZX Spectrum emulator support library."
+arch=('i686' 'x86_64')
+url="http://fuse-emulator.sourceforge.net/libspectrum.php"
+license=("GPL")
+conflicts=("libspectrum")
+depends=('libgcrypt' 'glib2' 'audiofile')
+source=("libspectrum::git+https://git.code.sf.net/p/fuse-emulator/libspectrum")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir"/libspectrum
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir"/libspectrum
+ make DESTDIR="$pkgdir" install
+}
+