summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkreon2015-07-07 03:37:54 +0300
committerkreon2015-07-07 03:37:54 +0300
commitea8057ad21cae2774e943b1ec6e04cbf04bee49e (patch)
tree2860dd27f558727f9e70ce971939afe7912e1064
downloadaur-ea8057ad21cae2774e943b1ec6e04cbf04bee49e.tar.gz
libspf2-git initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2204a5f7ab91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libspf2-git
+ pkgdesc = Implementation of the Sender Policy Framework for SMTP authorization
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.libspf2.org/
+ arch = i685
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ makedepends = git
+ provides = libspf2
+
+pkgname = libspf2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dde78403998
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=libspf2-git
+pkgver=1
+pkgrel=1
+pkgdesc="Implementation of the Sender Policy Framework for SMTP authorization"
+arch=('i685' 'x86_64')
+url="http://www.libspf2.org/"
+license=('GPL')
+makedepends=('gcc' 'git')
+provides=('libspf2')
+
+prepare() {
+ git clone https://github.com/shevek/libspf2.git
+}
+
+build() {
+ cd libspf2
+ ./configure --prefix=/usr
+ make
+}
+
+
+package() {
+ cd libspf2
+ make DESTDIR="$pkgdir/" install
+}