summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Nestler2016-02-08 23:36:00 +0100
committerRaphael Nestler2016-02-08 23:36:00 +0100
commitade087c4d830daf301b01a2c4a18f733ee53c8f9 (patch)
treeea3a348ab35674bace8e18b537e9baf87ef14bcc
downloadaur-ade087c4d830daf301b01a2c4a18f733ee53c8f9.tar.gz
Initial version
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4f79e632cfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Feb 8 22:35:08 UTC 2016
+pkgbase = libsphero-git
+ pkgdesc = Simple API for sphero 1 and 2.0 written in C++
+ pkgver = 1.0.r9.g23bce4a
+ pkgrel = 1
+ url = https://github.com/slock83/sphero-linux-api
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = bluez-libs
+ provides = libsphero
+ conflicts = libsphero
+ source = git://github.com/rnestler/sphero-linux-api#branch=fix_makefile
+ md5sums = SKIP
+
+pkgname = libsphero-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5060effa8474
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+src
+pkg
+sphero-linux-api
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8a79df6c234
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Raphael Nestler <raphael.nestler@gmail.com>
+
+_gitname=sphero-linux-api
+pkgname=libsphero-git
+pkgver=1.0.r9.g23bce4a
+pkgrel=1
+pkgdesc='Simple API for sphero 1 and 2.0 written in C++'
+arch=('i686' 'x86_64')
+url="https://github.com/slock83/sphero-linux-api"
+license=('GPL2')
+depends=(bluez-libs)
+makedepends=(git)
+provides=('libsphero')
+conflicts=('libsphero')
+source=('git://github.com/rnestler/sphero-linux-api#branch=fix_makefile')
+md5sums=(SKIP)
+
+pkgver() {
+ cd $_gitname
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
+}
+
+build() {
+ cd $_gitname
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR=$pkgdir/usr install
+}