summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-12-26 13:16:43 +0100
committerPhilip Goto2018-12-26 13:16:43 +0100
commit51c05634ade5fcdb204b304dbb1451112c4acab4 (patch)
treece2882b218d3478e96e88abb88eec713f068f167
parent824dcc91dd22925d3dba5ee27dab49f087d3dd9c (diff)
downloadaur-51c05634ade5fcdb204b304dbb1451112c4acab4.tar.gz
Update to 0.4.1 and update packaging
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5848062493c7..51c421f07cb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libspng
pkgdesc = C library for reading and writing PNG format files with a focus on security and ease of use
- pkgver = 0.4.0
+ pkgver = 0.4.1
pkgrel = 1
url = https://libspng.org/
arch = i686
@@ -11,8 +11,8 @@ pkgbase = libspng
makedepends = meson
depends = zlib
conflicts = libspng-git
- source = https://gitlab.com/randy408/libspng/-/archive/v0.4.0/libspng-v0.4.0.tar.gz
- md5sums = ae152da25d1cce7c392a0c1e81d22cb4
+ source = https://gitlab.com/randy408/libspng/-/archive/v0.4.1/libspng-v0.4.1.tar.gz
+ sha256sums = 4d27f8e201c0c940e81e6eb3b7a563ced3555e9902cd598bcd7dea8463c8ea24
pkgname = libspng
diff --git a/PKGBUILD b/PKGBUILD
index b1b8c3f2426f..5f60fcfeb788 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=libspng
-pkgver=0.4.0
+pkgver=0.4.1
pkgrel=1
pkgdesc="C library for reading and writing PNG format files with a focus on security and ease of use"
arch=(i686 x86_64 armv6h armv7h)
@@ -12,24 +12,20 @@ makedepends=(meson)
#checkdepends=(libpng)
conflicts=(libspng-git)
source=("https://gitlab.com/randy408/libspng/-/archive/v${pkgver}/libspng-v${pkgver}.tar.gz")
-md5sums=('ae152da25d1cce7c392a0c1e81d22cb4')
+sha256sums=('4d27f8e201c0c940e81e6eb3b7a563ced3555e9902cd598bcd7dea8463c8ea24')
build() {
- cd libspng-v${pkgver}
- rm -rf build
- arch-meson build
+ arch-meson build "libspng-v${pkgver}"
ninja -C build
}
#check() {
-# cd libspng-v${pkgver}
-# meson configure -Ddev_build=true build
-# ninja test -C build
+# cd build
+# meson configure -Ddev_build=true
+# ninja test
#}
package() {
- cd libspng-v${pkgver}
DESTDIR="${pkgdir}/" ninja -C build install
-
- install -D LICENSE "${pkgdir}/usr/share/licenses/libspng/LICENSE"
+ install -D "libspng-v${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/libspng/LICENSE"
}