summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-02-01 12:25:57 +0100
committerPhilip Goto2021-02-01 12:25:57 +0100
commitb5fe6e4995a08ae6041dfe070d1f1b108ade0370 (patch)
tree0400d97924509d2aec4993533c2241630bff65f9
parentba03d7ca8f01f8ff730458a973489b4531e3976f (diff)
downloadaur-b5fe6e4995a08ae6041dfe070d1f1b108ade0370.tar.gz
Update to 0.6.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 442e5f0eea25..d887a36f3a96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libspng
pkgdesc = C library for reading and writing PNG format files with a focus on security and ease of use
- pkgver = 0.6.1
+ pkgver = 0.6.2
pkgrel = 1
url = https://libspng.org/
arch = i686
@@ -12,8 +12,8 @@ pkgbase = libspng
makedepends = meson
depends = zlib
conflicts = libspng-git
- source = libspng-0.6.1::https://github.com/randy408/libspng/archive/v0.6.1.tar.gz
- sha256sums = 336856bea0216fe0ddc6cc584be5823cfd3a142e9d90d8e1635d2d2a5241f584
+ source = libspng-0.6.2.tar.gz::https://github.com/randy408/libspng/archive/v0.6.2.tar.gz
+ sha256sums = eb7faa3871e7a8e4c1350ab298b513b859fcb4778d15aa780a79ff140bcdfaf3
pkgname = libspng
diff --git a/PKGBUILD b/PKGBUILD
index c67d77eb6ea2..aff6b98bbab7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=libspng
-pkgver=0.6.1
+pkgver=0.6.2
pkgrel=1
pkgdesc="C library for reading and writing PNG format files with a focus on security and ease of use"
arch=(i686 x86_64 armv7 aarch64)
@@ -11,21 +11,19 @@ depends=(zlib)
makedepends=(meson)
checkdepends=(libpng)
conflicts=(libspng-git)
-source=("libspng-${pkgver}::https://github.com/randy408/libspng/archive/v${pkgver}.tar.gz")
-sha256sums=('336856bea0216fe0ddc6cc584be5823cfd3a142e9d90d8e1635d2d2a5241f584')
+source=("libspng-${pkgver}.tar.gz::https://github.com/randy408/libspng/archive/v${pkgver}.tar.gz")
+sha256sums=('eb7faa3871e7a8e4c1350ab298b513b859fcb4778d15aa780a79ff140bcdfaf3')
build() {
- arch-meson build "libspng-${pkgver}"
- ninja -C build
+ arch-meson build "libspng-${pkgver}"
+ meson compile -C build
}
check() {
- cd build
- meson configure -Ddev_build=true
- ninja test
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="${pkgdir}/" ninja -C build install
- install -D "libspng-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/libspng/LICENSE"
+ DESTDIR="${pkgdir}" meson install -C build
+ install -D "libspng-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/libspng/LICENSE"
}