summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-09-20 12:36:41 +0200
committerPhilip Goto2018-09-20 12:36:41 +0200
commitc5ad0f9b5a137e17e4a6705b0527c87b5f7bc577 (patch)
treefcf9d49643127ce0344240479c62f9f65c6ac046
downloadaur-c5ad0f9b5a137e17e4a6705b0527c87b5f7bc577.tar.gz
Initialize package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f065dbab948a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libspng
+ pkgdesc = C library for reading and writing PNG format files with a focus on security and ease of use
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://libspng.org/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = BSD
+ checkdepends = libpng
+ makedepends = meson
+ depends = zlib
+ conflicts = libspng-git
+ source = https://gitlab.com/randy408/libspng/-/archive/v0.3.1/libspng-v0.3.1.tar.gz
+ md5sums = 8b4ca63f52cfc5034754341d1544b2dd
+
+pkgname = libspng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d621ee6fabe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=libspng
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="C library for reading and writing PNG format files with a focus on security and ease of use"
+arch=(i686 x86_64 armv6h armv7h)
+url="https://libspng.org/"
+license=('BSD')
+depends=(zlib)
+makedepends=(meson)
+checkdepends=(libpng)
+conflicts=(libspng-git)
+source=("https://gitlab.com/randy408/libspng/-/archive/v${pkgver}/libspng-v${pkgver}.tar.gz")
+md5sums=('8b4ca63f52cfc5034754341d1544b2dd')
+
+build() {
+ cd libspng-v${pkgver}
+ rm -rf build
+ arch-meson build
+ ninja -C build
+}
+
+check() {
+ cd libspng-v${pkgver}
+ meson configure -Ddev_build=true build
+ ninja test -C build
+}
+
+package() {
+ cd libspng-v${pkgver}
+ DESTDIR="${pkgdir}/" ninja -C build install
+
+ install -D LICENSE "${pkgdir}/usr/share/licenses/libspng/LICENSE"
+}