summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-08-15 14:03:41 +0200
committerPhilip Goto2019-08-15 14:03:41 +0200
commite36e1695333ef881b3adc682fd802a518f674fbe (patch)
tree81c1247512af3a69f5825cb439caea7861811bea
parent1bc78b46e274f8c1029e93c9db89fd06d2abfa7e (diff)
downloadaur-e36e1695333ef881b3adc682fd802a518f674fbe.tar.gz
Update to 0.5.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a9ca8643452..886bc84557b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libspng
pkgdesc = C library for reading and writing PNG format files with a focus on security and ease of use
- pkgver = 0.4.5
+ pkgver = 0.5.0
pkgrel = 1
url = https://libspng.org/
arch = i686
@@ -8,11 +8,12 @@ pkgbase = libspng
arch = armv6h
arch = armv7h
license = BSD
+ checkdepends = libpng
makedepends = meson
depends = zlib
conflicts = libspng-git
- source = https://gitlab.com/randy408/libspng/-/archive/v0.4.5/libspng-v0.4.5.tar.gz
- sha256sums = 69924b59dfa2d52a024d389637fbdd245ba7e7b61fa1347af23d4c9e77814392
+ source = https://gitlab.com/randy408/libspng/-/archive/v0.5.0/libspng-v0.5.0.tar.gz
+ sha256sums = 8864e89e4acf7aa1bd246ed7411643ec5cc85f9e7db1b9ef5f55079638e91332
pkgname = libspng
diff --git a/PKGBUILD b/PKGBUILD
index 89b4ec246fb5..5a8949ea31ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=libspng
-pkgver=0.4.5
+pkgver=0.5.0
pkgrel=1
pkgdesc="C library for reading and writing PNG format files with a focus on security and ease of use"
arch=(i686 x86_64 armv6h armv7h)
@@ -9,21 +9,21 @@ url="https://libspng.org/"
license=('BSD')
depends=(zlib)
makedepends=(meson)
-#checkdepends=(libpng)
+checkdepends=(libpng)
conflicts=(libspng-git)
source=("https://gitlab.com/randy408/libspng/-/archive/v${pkgver}/libspng-v${pkgver}.tar.gz")
-sha256sums=('69924b59dfa2d52a024d389637fbdd245ba7e7b61fa1347af23d4c9e77814392')
+sha256sums=('8864e89e4acf7aa1bd246ed7411643ec5cc85f9e7db1b9ef5f55079638e91332')
build() {
arch-meson build "libspng-v${pkgver}"
ninja -C build
}
-#check() {
-# cd build
-# meson configure -Ddev_build=true
-# ninja test
-#}
+check() {
+ cd build
+ meson configure -Ddev_build=true
+ ninja test
+}
package() {
DESTDIR="${pkgdir}/" ninja -C build install