summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-12-23 21:28:47 +0100
committerPhilip Goto2018-12-23 21:28:47 +0100
commitdb3725a05cc65d08fdb8cb1b8b32a6098ca0681c (patch)
tree39e3e7261ee019b423aefa84b2ccf47917cc1c30
parentef8c6b62743ec505e7640b11906f1b470f9d33a5 (diff)
downloadaur-db3725a05cc65d08fdb8cb1b8b32a6098ca0681c.tar.gz
Update build process
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a34069441b15..617ee19b96a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libspng-git
pkgdesc = C library for reading and writing PNG format files with a focus on security and ease of use
- pkgver = 0.3.1.r2.gf77e500
+ pkgver = 0.4.1.r2.gdf82205
pkgrel = 1
url = https://libspng.org/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 6b826f6d9102..8d9f4eb4db1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=libspng-git
-pkgver=0.3.1.r2.gf77e500
+pkgver=0.4.1.r2.gdf82205
pkgrel=1
pkgdesc="C library for reading and writing PNG format files with a focus on security and ease of use"
arch=(i686 x86_64 armv6h armv7h)
@@ -21,21 +21,17 @@ pkgver() {
}
build() {
- cd libspng
- rm -rf build
- arch-meson build
+ arch-meson build libspng
ninja -C build
}
#check() {
-# cd libspng
-# meson configure -Ddev_build=true build
-# ninja test -C build
+# cd build
+# meson configure -Ddev_build=true
+# ninja test
#}
package() {
- cd libspng
DESTDIR="${pkgdir}/" ninja -C build install
-
- install -D LICENSE "${pkgdir}/usr/share/licenses/libspng/LICENSE"
+ install -D "libspng/LICENSE" "${pkgdir}/usr/share/licenses/libspng/LICENSE"
}