summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfademind2018-04-23 15:27:24 +0200
committerfademind2018-04-23 15:27:24 +0200
commitb680896fff698cb60e6fdb18464836b0ee4b71bb (patch)
treed211dfee37d035d92a3dd03a40a96c6c1707b1d7
parentb58c2287eeed003a37b999d8a300698b2df52588 (diff)
downloadaur-b680896fff698cb60e6fdb18464836b0ee4b71bb.tar.gz
change source, del arm arch, add notice
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD54
3 files changed, 37 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b96580b6614..423067a4d5a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
+# Generated by mksrcinfo v8
+# Mon Apr 23 13:26:47 UTC 2018
pkgbase = libspotify
pkgdesc = C API package allowing third-party developers to write applications that utilize the Spotify music streaming service
pkgver = 12.1.51
- pkgrel = 3
+ pkgrel = 4
url = https://developer.spotify.com/technologies/libspotify/
arch = i686
arch = x86_64
- arch = armv7h
- arch = armv6h
license = custom
depends = glibc
- source = http://developer.spotify.com/download/libspotify/libspotify-12.1.51-Linux--release.tar.gz
pkgname = libspotify
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
index e15b5c5e1d89..cc74950dbc52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,50 @@
-# Maintainer: Richard Weber <old-box at outlook dot com>
+# Maintainer: FadeMind <fademind@gmail.com>
+# Contributor: Richard Weber <old-box at outlook dot com>
# Contributor: Benjamin Hedrich <kiwisauce at pagenotfound dot de>
# Contributor: Thomas Jost <schnouki at schnouki dot net>
# Contributor: Tomas Strand <tomas at fik1 dot net>
+
+### NOTICE
+### libspotify is EOL, sources are taken from https://pkgs.rpmfusion.org/repo/pkgs/nonfree/libspotify/ mirror and reuploaded to private Google Drive Storage.
+### URLs were shortened via is.gd tool cause they are soo long. Checksums they have not been changed.
+###
+### SPOTIFY DEVS STATEMENT
+###
+### Please note that we have removed the LibSpotify binaries from our website in an effort to phase out the usage of this deprecated library.
+### LibSpotify has been considered deprecated since 2015 and will be shut down in 2017, so we want to ensure that all developers’ efforts and
+### attention are focused on newer and better APIs that we actively support and maintain. These APIs include the Web API, iOS and Android SDKs,
+### and upcoming embedded libraries for Windows, Mac OS X and Linux. More information regarding upcoming libraries will be provided in the coming months.
+###
+###
+### Source: https://is.gd/z6waBx
+###
+###
+
pkgname=libspotify
pkgver=12.1.51
-pkgrel=3
+pkgrel=4
pkgdesc="C API package allowing third-party developers to write applications that utilize the Spotify music streaming service"
-arch=(i686 x86_64 armv7h armv6h)
+arch=("i686" "x86_64")
url="https://developer.spotify.com/technologies/libspotify/"
license=('custom')
depends=('glibc')
-if [ "$CARCH" == "armv6h" ]; then
- pkgver=12.1.103
- SPOTIFY_ARCH="armv6-bcm2708hardfp"
- md5sums=('bf9afc8c7b966841735734b248f9c7a7')
- sha256sums=('d658e6c1978fb46cf33376eb8367a51d024f4014f21beac1dd264532bcc54b24')
-fi
-
-if [ "$CARCH" == "armv7h" ]; then
- SPOTIFY_ARCH="armv7"
- md5sums=('eb7e98849b3bb6d364fa74034602afbf')
- sha256sums=('ad27b6c5aee5382b66b39bfea3b1752076b7abcc445979ce25c1ec9d7ff3aeda')
-fi
-
if [ "$CARCH" == "x86_64" ]; then
SPOTIFY_ARCH="x86_64"
- md5sums=('83efddcc195d6ff12b24c97c767a5e45')
- sha256sums=('43a14e0732ba6ae30078fac105d0e2998d04d5f5c396a4968386bc4e22491058')
+ source_x86_64=("${pkgname}-${pkgver}-Linux-${SPOTIFY_ARCH}-release.tar.gz::https://is.gd/HwQUT6")
+ md5sums_x86_64=('83efddcc195d6ff12b24c97c767a5e45')
+ sha256sums_x86_64=('43a14e0732ba6ae30078fac105d0e2998d04d5f5c396a4968386bc4e22491058')
fi
if [ "$CARCH" == "i686" ]; then
SPOTIFY_ARCH="i686"
- md5sums=('04735b890da0b1fc7f1f14e68a5293de')
- sha256sums=('941ab4ba10bcd6ec4e96127afd095a39e11bc955de0882734c97e4f588b155ae')
-
+ source_i686=("${pkgname}-${pkgver}-Linux-${SPOTIFY_ARCH}-release.tar.gz::https://is.gd/rzULo7")
+ md5sums_i686=('04735b890da0b1fc7f1f14e68a5293de')
+ sha256sums_i686=('941ab4ba10bcd6ec4e96127afd095a39e11bc955de0882734c97e4f588b155ae')
fi
-source=(http://developer.spotify.com/download/libspotify/libspotify-${pkgver}-Linux-${SPOTIFY_ARCH}-release.tar.gz)
-
build() {
- cd "$srcdir/$pkgname-$pkgver-Linux-${SPOTIFY_ARCH}-release"
+ cd "${srcdir}/${pkgname}-${pkgver}-Linux-${SPOTIFY_ARCH}-release"
# Don't do stupid things from a Makefile
msg2 "Patching Makefile..."
@@ -48,7 +52,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver-Linux-${SPOTIFY_ARCH}-release"
+ cd "${srcdir}/${pkgname}-${pkgver}-Linux-${SPOTIFY_ARCH}-release"
make prefix="$pkgdir/usr" install