summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavorin Učakar2015-12-25 01:44:58 +0100
committerDavorin Učakar2015-12-25 01:44:58 +0100
commit9d52c1d1f5347bc9509ed57740afbe432123da6d (patch)
tree203278c8692f2538d3ef53fea9ab5fd21057b3c6
parent83489905dc5f35ee52c064e2f6ba0c4868272add (diff)
downloadaur-9d52c1d1f5347bc9509ed57740afbe432123da6d.tar.gz
Updated to 1.13
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD49
-rw-r--r--config22
-rw-r--r--gcc440.patch11
5 files changed, 27 insertions, 99 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ee0897b5e6b..ec4e38999edb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Dec 24 22:30:19 UTC 2015
pkgbase = libsquish
pkgdesc = DXT compression library
- pkgver = 1.11
- pkgrel = 2
- url = http://code.google.com/p/libsquish
+ pkgver = 1.13
+ pkgrel = 1
+ url = http://sourceforge.net/projects/libsquish/
arch = i686
arch = x86_64
license = MIT
- options = staticlibs
- source = http://libsquish.googlecode.com/files/squish-1.11.zip
- source = gcc440.patch
- source = config
- source = LICENSE
- sha1sums = 1fdff1ba72a002900c877baebcf0aeab9af4922b
- sha1sums = 51bcc11eafbf79d9cde24769397c7a42f886154a
- sha1sums = db587e6251b850820d7ce6edaf8eccb180c24b99
- sha1sums = e285c60d401f91f282de6ad6b6f549e9f5e9ff1d
+ depends = gcc-libs
+ source = http://downloads.sourceforge.net/project/libsquish/libsquish-1.13.tgz
+ md5sums = ca4b9563953ad6ea9c43f7831a8c50c7
pkgname = libsquish
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index dd0f22eb9435..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-/* -----------------------------------------------------------------------------
-
- Copyright (c) 2006 Simon Brown si@sjbrown.co.uk
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
- "Software"), to deal in the Software without restriction, including
- without limitation the rights to use, copy, modify, merge, publish,
- distribute, sublicense, and/or sell copies of the Software, and to
- permit persons to whom the Software is furnished to do so, subject to
- the following conditions:
-
- The above copyright notice and this permission notice shall be included
- in all copies or substantial portions of the Software.
-
- THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
- OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
- MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
- IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
- CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
- TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
- SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
- -------------------------------------------------------------------------- */
diff --git a/PKGBUILD b/PKGBUILD
index de58b5515b33..a435750cd42a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,33 @@
# Maintainer: Davorin Učakar <davorin.ucakar@gmail.com>
pkgname=libsquish
-pkgver=1.11
-pkgrel=2
-pkgdesc="DXT compression library"
+pkgver=1.13
+pkgrel=1
+pkgdesc='DXT compression library'
+depends=('gcc-libs')
arch=('i686' 'x86_64')
-url="http://code.google.com/p/libsquish"
+url='http://sourceforge.net/projects/libsquish/'
license=('MIT')
-options=(staticlibs)
-source=(http://libsquish.googlecode.com/files/squish-$pkgver.zip
- gcc440.patch
- config
- LICENSE)
-sha1sums=('1fdff1ba72a002900c877baebcf0aeab9af4922b'
- '51bcc11eafbf79d9cde24769397c7a42f886154a'
- 'db587e6251b850820d7ce6edaf8eccb180c24b99'
- 'e285c60d401f91f282de6ad6b6f549e9f5e9ff1d')
-
-prepare() {
- cd "$srcdir/squish-$pkgver"
- cp $srcdir/config .
-
- patch -Np0 -i $srcdir/gcc440.patch
-}
+source=("http://downloads.sourceforge.net/project/libsquish/libsquish-${pkgver}.tgz")
+md5sums=('ca4b9563953ad6ea9c43f7831a8c50c7')
build() {
- cd "$srcdir/squish-$pkgver"
+ rm -rf "$srcdir/build" && mkdir -p "$srcdir/build" && cd "$srcdir/build"
- make || return 1
+ cmake \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D BUILD_SHARED_LIBS=ON \
+ ..
+
+ make
}
package() {
- cd "$srcdir/squish-$pkgver"
-
- mkdir -p $pkgdir/usr/{include,lib}
+ cd "$srcdir/build"
- install -Dm 644 squish.h $pkgdir/usr/include/squish.h
- install -Dm 644 libsquish.a $pkgdir/usr/lib/libsquish.a
+ cmake -D CMAKE_INSTALL_PREFIX="$pkgdir/usr" -P cmake_install.cmake
- install -Dm 644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm 644 ../CMakeModules/FindlibSquish.cmake "$pkgdir/usr/share/cmake/Modules/FindlibSquish.cmake"
+ install -Dm 644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/config b/config
deleted file mode 100644
index 715ef6492e1c..000000000000
--- a/config
+++ /dev/null
@@ -1,22 +0,0 @@
-# config file used for the Makefile only
-
-# define to 1 to use Altivec instructions
-USE_ALTIVEC ?= 0
-
-# define to 1 to use SSE2 instructions
-USE_SSE ?= 1
-
-# default flags
-CXXFLAGS = -Ofast -fPIC
-ifeq ($(USE_ALTIVEC),1)
-CPPFLAGS += -DSQUISH_USE_ALTIVEC=1
-CXXFLAGS += -maltivec
-endif
-ifeq ($(USE_SSE),1)
-CPPFLAGS += -DSQUISH_USE_SSE=2
-CXXFLAGS += -msse2
-endif
-
-# where should we install to
-INSTALL_DIR ?= /usr/local
-
diff --git a/gcc440.patch b/gcc440.patch
deleted file mode 100644
index 48f52242aaa3..000000000000
--- a/gcc440.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- squish.h 2009-09-02 21:25:02.586265731 +0200
-+++ squish.h 2009-09-02 21:24:47.922933766 +0200
-@@ -26,6 +26,8 @@
- #ifndef SQUISH_H
- #define SQUISH_H
-
-+#include <limits.h>
-+
- //! All squish API functions live in this namespace.
- namespace squish {
-