summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasm0dey2018-02-10 09:27:03 +0300
committerasm0dey2018-02-10 09:58:02 +0300
commitaaa3129f200a38bec6adac4d3617945daf43af15 (patch)
tree10790c0fe55dd9bd78da47fadf1e8522cda9057b
parent83dd4026918844f3af146ba6300f9d5feb766b43 (diff)
downloadaur-aaa3129f200a38bec6adac4d3617945daf43af15.tar.gz
Adds description and license to package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 239585aa0b6a..2b78e1f2be26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = libsrtp0
+ pkgdesc = provides an implementation of the Secure Real-time Transport Protocol (SRTP), compatible with 0th version of lib
pkgver = 1.6.0
pkgrel = 1
url = https://github.com/cisco/libsrtp
arch = i686
arch = x86_64
license = BSD
+ depends = glibc
source = v1.6.0.tar.gz::https://github.com/cisco/libsrtp/archive/v1.6.0.tar.gz
+ source = LICENSE::https://raw.githubusercontent.com/cisco/libsrtp/master/LICENSE
md5sums = 0f2188e50468a52cdd51d0479849236a
+ md5sums = 2909fcf6f09ffff8430463d91c08c4e1
pkgname = libsrtp0
diff --git a/PKGBUILD b/PKGBUILD
index 977f52dd7f09..188bff4a689b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,11 @@ arch=('i686' 'x86_64')
url="https://github.com/cisco/libsrtp"
license=("BSD")
-source=("v$pkgver.tar.gz::https://github.com/cisco/libsrtp/archive/v$pkgver.tar.gz")
-md5sums=('0f2188e50468a52cdd51d0479849236a')
+pkgdesc='provides an implementation of the Secure Real-time Transport Protocol (SRTP), compatible with 0th version of lib'
+source=("v$pkgver.tar.gz::https://github.com/cisco/libsrtp/archive/v$pkgver.tar.gz" "LICENSE::https://raw.githubusercontent.com/cisco/libsrtp/master/LICENSE")
+md5sums=('0f2188e50468a52cdd51d0479849236a' '2909fcf6f09ffff8430463d91c08c4e1')
+depends=("glibc")
prepare() {
sed -i 's|SHAREDLIBVERSION = 1|SHAREDLIBVERSION = 0|' "$srcdir/libsrtp-$pkgver/Makefile.in"
}
@@ -23,4 +25,6 @@ build() {
package() {
cd "libsrtp-$pkgver"
make DESTDIR="$pkgdir/" install
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
+ cp "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}