summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-11-09 10:44:45 -0500
committerfrealgagu2018-11-09 10:44:45 -0500
commita82356e033d99f6791803893c343a83c0c06c7d2 (patch)
tree527edaf898dbec1a55101f9af60f56dcb80ad37a
downloadaur-a82356e033d99f6791803893c343a83c0c06c7d2.tar.gz
Initial commit.
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD57
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df14eda0d355
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = libssh-gnutls
+ pkgdesc = Library for accessing ssh client services through C libraries - compiled with gnutls (libgcrypt)
+ pkgver = 0.8.5
+ pkgrel = 1
+ url = http://www.libssh.org/
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = cmocka
+ makedepends = doxygen
+ makedepends = python
+ depends = libgcrypt
+ depends = zlib
+ provides = libssh
+ conflicts = libssh
+ source = https://www.libssh.org/files/0.8/libssh-0.8.5.tar.xz
+ source = https://www.libssh.org/files/0.8/libssh-0.8.5.tar.xz.asc
+ validpgpkeys = 8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D
+ sha256sums = 07d2c431240fc88f6b06bcb36ae267f9afeedce2e32f6c42f8844b205ab5a335
+ sha256sums = SKIP
+
+pkgname = libssh-gnutls
+
+pkgname = libssh-gnutls-docs
+ pkgdesc = Documentation for libssh
+ arch = any
+ depends =
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67b156d08550
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+libssh-*.tar.xz
+libssh-*.tar.xz.asc
+libssh-gnutls-*.pkg.tar.xz
+libssh-gnutls-docs-*.pkg.tar.xz
+libssh-gnutls-*.log
+libssh-gnutls-docs-*.log
+PKGBUILD-namcap.log
+pkg/
+src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6aa2604bd45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+
+pkgbase=libssh-gnutls
+pkgname=(${pkgbase} ${pkgbase}-docs)
+pkgver=0.8.5
+pkgrel=1
+pkgdesc="Library for accessing ssh client services through C libraries - compiled with gnutls (libgcrypt)"
+arch=("x86_64")
+url="http://www.libssh.org/"
+license=("LGPL")
+depends=("libgcrypt" "zlib")
+makedepends=("cmake" "cmocka" "doxygen" "python")
+provides=("${pkgname%-gnutls}")
+conflicts=("${pkgname%-gnutls}")
+source=("https://www.libssh.org/files/${pkgver%.*}/${pkgname%-gnutls}-${pkgver}.tar.xz"{,.asc})
+sha256sums=("07d2c431240fc88f6b06bcb36ae267f9afeedce2e32f6c42f8844b205ab5a335"
+ "SKIP")
+validpgpkeys=("8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D") # Andreas Schneider <asn@cryptomilk.org>
+
+prepare() {
+ cd "${srcdir}"
+ # disable the test. It is confused by our clean container setup.
+ # 'extra-x86-build' uses user 'nobody' that has a record in /etc/passwd file
+ # but $HOME envvar is set to '/build'. The test expects that $HOME corresponds to passwd file.
+ sed "s/cmocka_unit_test(torture_path_expand_tilde_unix),//" -i "libssh-${pkgver}/tests/unittests/torture_misc.c"
+ mkdir -p "${srcdir}/build"
+}
+
+build() {
+ cd "${srcdir}/build"
+ cmake ../${pkgname%-gnutls}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_GSSAPI=OFF \
+ -DWITH_GCRYPT=ON \
+ -DUNIT_TESTING=ON
+ make
+ make docs
+}
+
+check() {
+ cd "${srcdir}/build"
+ make test
+}
+
+package_libssh-gnutls() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}
+
+package_libssh-gnutls-docs() {
+ pkgdesc="Documentation for libssh"
+ arch=("any")
+ depends=()
+
+ mkdir -p "${pkgdir}/usr/share/doc/libssh"
+ cp -r "build/doc/html" "${pkgdir}/usr/share/doc/libssh"
+}